The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

"500 Connection Refused" when trying to access cDOT 8.2.1 Cluster from OnCmd SysMgr 3.1.1

relaxdad

I suspect a network setup issue. The installation instructions for 8.2.1 for VMwrkstn say to use VMnet8 and also to use it's IP address as assigned (displayed via ipconfig) for cluster mgt and to ignore the gateway request; the gateway request can't be ignored so I used the same address. The Cluster appears to be up and a "net int show" displays the VMnet8 address for cluster_mgmt. I was also able to join in a 2nd controller.

 

I provided the Cluster Mgt (VMnet8) IP address and credentials to the "add" function in OnCmd and after a few seconds, the box line around the address turns red and a hover produces "500 Connection Refused".

 

Steve

8 REPLIES 8

F_SCHUBERT

I am also looking for a solution of this using Snaplock SnapVault controlled by DFM. Do you have any idea how to set the retention period using DFM?

lwangnetapp

I have recently encountered all kinds of problem after my W7 workstation was patched with MS security updates and java 8 (java is nasty, isn't it?) regarding to NetApp SystemManager 3.1.2 (SM312).

 

First, the error is "500 Connection Refused"", then "HTTP XML Authentica​tion failed from x.x.x.x (DFM server) on Netapp controller", and last the KS file corruption.

 

I tried to remove java 8, then remove and re-install Java (jre-7u65) and SM312; did not work.

 

Of course, you have to install jre-7u65 and SM.

 

Next, recovere the SM.config file from C:\Users\myusername\NetApp\SystemManager using SMBackup.config, simply deleted the SM.config file then recreate the file using backup (you know how to do this, don't yuo?); deleted the KS file. This restored my previous connections to my filers, great, one step closer.

 

Next, putty to the filers (controllers) and run this command: "options tls.enable on", bingo, my SM back to work.

 

Thanks, guys. Good Luck.

 

1- putty(ssh)  into each controller

2- run "options tls.enable on"

 

Fixed... don't bother with the Java fiasco. Mind you, every time I have a java dependant device, I always have problems; they should stop using the platform all together and use something else, such as .NET

Thank you for All your help . I've been hitting head against the wall for a while.

nicholaf

What is the output of net int show? What is the VMNet8 address/gateway/subnet? What is the output of ipconfig of the host with the VM? And, what is the output of ipconfig/ifconfig of the client you have OnCommand System Manager on?

 

Regards,

 

Nicholas Lee Fagan

relaxdad

This is all running on my Windows7 laptop. Hopefully my attachment is included; it shows the ipconfig/all.

 

The following graphic shows the VM (vsim_netapp-cm) settings:

 

The following shows the net int show command output:

net int show.JPG

 

Note: When I rebuilt the cluster to use the VMnet8 IP addr, I only created the 1st node in the cluster. Previously I had both nodes in the cluster so I know that part is OK.

 

ANY help with these parameters would be appreciated.

 

Thanks

 

Steve

shatfield

I've seen that symptom in the 8.2.1 7mode sim, and the fix in that instance is options httpd.admin.enable on and options httpd.admin.ssl.enable on.

 

Haven't seen it in CDOT, but it sounds similar.  Check options at the cluster shell.  httpd.admin.enable should be on.

 

Also check these:

system services web show

system services web node show

vserver services web show

 

Also check the IP settings of the host interface on VMnet8.  Usually .1 and .2 go to the host and vmnet gateway service.  It could simply be an IP conflict on that subnet.

 

beegandhi

This two options worked for me as well

options httpd.admin.enable on and options httpd.admin.ssl.enable on.

 

Thank you,

relaxdad

As I suspected from the start, the network setup was a little off. Setting all adapters to VMnet8, using VMnet8's IP as the gateway, and VMnet8's subnet did the trick. All of the other potential areas were set OK (httpd.admin.enable was on). It would be helpful if someone did a small writeup that simplified setup of the VM simulator's network adapters. The 8.2 and 8.2.1 instructions were a little different and basically said that the adapters needed to be configured but didn't specifically say how.

 

Thanks Shatfield for the help.

 

Steve

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public