Community maintenance is complete. Thank you for your patience!

Active IQ Unified Manager Discussions

zexplore API for Custom Eventtype creation failed saying missing value

bipul34_gogoi

Hi ,  i am trying to create a customer eventtype following the disscussion 

 

https://communities.netapp.com/message/92172#92172 of Adai 

 

My dfm version is 5.2R1 and i am using zexplore from SDK 5.6 .  However , even if i am using same code as mentioned  in the disscussion , Its not able to find the values , It there any sntex problem ?

 

Code :

 

<?xml version="1.0" encoding="UTF-8"?>
<netapp xmlns="http://www.netapp.com/filer/admin" version="1.0">
<eventclass-add-custom>
<about-message>This event is custom created</about-message>
<event-class-name>CloneSavings</event-class-name>
<event-names>
<event-name-info>
<event-name-pretty>Clone Space Saving Is Low </event-name-pretty>
<event-name-short>LowCloneSpaceSaving</event-name-short>
<severity>Error</severity>
</event-name-info>
</event-names>
<event-namespace-name>OpsMgr</event-namespace-name>
</eventclass-add-custom>
</netapp>

 

Result ::

 

<?xml version='1.0' encoding='UTF-8' ?>
<netapp version='1.0' xmlns='http://www.netapp.com/filer/admin'>

<!-- Output of eventclass-add-custom [Execution Time: 51 ms] -->
<results errno='13006' status='failed' reason='Missing required input(s) - about-message, event-class-name, event-names, event-namespace-name'/>
</netapp>

 

Can you please help here

 

Thanks

Bipul

1 ACCEPTED SOLUTION

bipul34_gogoi

Never Mind , I fixed the issue with below code , Not sure whats the differences , may be some space etc 

 

<?xml version="1.0" encoding="UTF-8"?>
<netapp xmlns="http://www.netapp.com/filer/admin" version="1.0">
<eventclass-add-custom>
<about-message>This event is custom created</about-message>
<event-class-name>Snapmirror_lag</event-class-name>
<event-names>
<event-name-info>
<event-name-pretty>Snapmirror_lag Is High </event-name-pretty>
<event-name-short>Snapmirror_lag</event-name-short>
<severity>Information</severity>
</event-name-info>
</event-names>
<event-namespace-name>OpsMgr</event-namespace-name>
<is-allow-duplicates>Yes</is-allow-duplicates>
<is-multi-current>Yes</is-multi-current>
</eventclass-add-custom>
</netapp>

View solution in original post

1 REPLY 1

bipul34_gogoi

Never Mind , I fixed the issue with below code , Not sure whats the differences , may be some space etc 

 

<?xml version="1.0" encoding="UTF-8"?>
<netapp xmlns="http://www.netapp.com/filer/admin" version="1.0">
<eventclass-add-custom>
<about-message>This event is custom created</about-message>
<event-class-name>Snapmirror_lag</event-class-name>
<event-names>
<event-name-info>
<event-name-pretty>Snapmirror_lag Is High </event-name-pretty>
<event-name-short>Snapmirror_lag</event-name-short>
<severity>Information</severity>
</event-name-info>
</event-names>
<event-namespace-name>OpsMgr</event-namespace-name>
<is-allow-duplicates>Yes</is-allow-duplicates>
<is-multi-current>Yes</is-multi-current>
</eventclass-add-custom>
</netapp>

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public