Active IQ and AutoSupport Discussions

Administrator doesn't have permissions for folder ONTAP1-CIFS

sce
416 Views

Hello,

can you please help me how can I set permissions for folder \\ONTAP1-CIFS\ONTAP_ADMIN$\ ?

It is NetApp 9.10.1 Simulator.

I've set permissions on shared folders, please see attached screenshot.

 

When I tried open this folder through our web application I've got this error:

Administrator doesn't have permissions for folder folderId = \\ONTAP1-CIFS\ONTAP_ADMIN$\; rootPath = 2

 

Thank you in advance for your help.

4 REPLIES 4

Ontapforrum
407 Views

Is the user/service-account part of Domain Admin group or the local BUILTIN\Administrators group on the NetApp?

 

Following kb just for reference:
https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/ONTAP_OS/Connecting_CIFS_shares_via_MMC_results_in_error_You_do_not_have_permis...

 

Also, I am assuming you have setup your Simulator/SVM/CIFS & joined to Active Directory ? What is the security style of the CIFS folder and also what exactly you are trying to achieve via the web application you mentioned? Have you checked the time difference between the filer and the host (web application) should be with-in 5mnt ?

sce
401 Views

I've found that only user "test" has access for folder \\ONTAP1-CIFS\ONTAP_ADMIN$\
"test" user's access has been allowed using the following command:

vserver fpolicy policy modify -vserver svm1 -policy-name mam_policy -events cifs_event -engine policy_engine -is-mandatory false -allow-privileged-access yes -privileged-user-name demo\test -is-passthrough-read-enabled false

How can I allow access to next user, please?
I would like to have allowed access for multiple users.

All desired users are part of BUILTIN\Administrators group.

sce
345 Views

All desired users are part of Domain Admin and BUILTIN\Administrators group.
I think I'm joined to Active Directory, I see in System Manager > Storage VMs >  VM Settings:

SMB/CIFS
STATUS
Enabled
SMB SERVER NAME
ONTAP1-CIFS
AUTHENTICATION STYLE
Active Directory
ACTIVE DIRECTORY DOMAIN NAME
DEMO.LOCAL
 
Is it correct please or how can I verify that it is properly joined to AD?
Where can I find settings for security style of the CIFS folder, please?
I'm trying to get folders via the web application. And I can only get folders when I am logged in as a 'demo\test' user in the web application.
With user 'test' I see the following folder structure:
ONTAP1-CIFS\ONTAP_ADMIN$\share\<all subfolders>

With another user I see only ONTAP1-CIFS\ONTAP_ADMIN$

sce
251 Views

The answer did not help to solve the problem.
Any other suggestions on how to fix this, please?

Public