Ask The Experts

Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

Installed the powershell toolkit 9.7 today and it seems to be working generally, but when I try to run the Show-NcHelp cmdlet it fails with this error:

WARNING: Could not launch browser: The system cannot find the file specified

tried running powershell as administrator but that did not help

tried adding the -Debug and -Verbose options when running the command in powershell but they returned no additional information.

I've attached a jpeg of the error, for what it's worth.

 

Any help in resolving this issue is appreciated

13 REPLIES 13

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

Show-NcHelp is designed to copy all of the help files from the module path itself to a temporary directory (For Cluster-Mode, it is $TEMP\webhelp.c) and then open the "index.html" page within that temporary directory in your web browser of choice. It looks like the function isn't able to find the index.html file for some reason. From your PowerShell session, can you run:

 

Test-Path $env:TEMP\webhelp.C\index.html


If that file exists, it'll return "True" (if not, it'll return "False"). Alternatively, you could browse to that temp folder location with Windows Explorer and see if that path exists.

 

If it does exist, can you double-click it and launch it interactively? What is your machine's default browser? 

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

Thanks for the reply Donny.  When I run that command it returns false:

PS C:\Users\sbarbe> test-path $env:TEMP\webhelp.C\index.html
False
PS C:\Users\sbarbe>

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

Interesting, so it looks like that directory isn't even being created in your Temp folder path. Are you running PowerShell as an administrator? 

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

I tried running PowerShell as Administrator - same error. Very strange.

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

I have run it as a normal user and as administrator with no change.

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

So today my manager had experienced this issue on one of our servers. After poking around a bit, he found a possible workaround. 

 

Try running the -herlp command in PowerShell and let it fail. Then open File Explorer and go to the user profile:  Users\UserName\AppData\Local\Temp\webhelp.C   - (it's possible this path may vary slightly).

 

In this folder there you'll find the html links that open the help page.  It's not ideal, but so far appears to work.

 

Here's hoping they release a fix to this problem.

 

-Doug

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

I had noticed this as well, but I'm also seeing an issue where it will create the html versions of the help files, but it doesn't finish.

The last html file in my list after this happens is:

C:\Users\sbarbe\AppData\Local\Temp\webhelp.C\cmdlet_Reset-NcNameServiceDNSStatistics.html

but if you run get-nchelp, the list continues until the end with the write-NcFile command, which I presume should create an html file:

C:\Users\sbarbe\AppData\Local\Temp\webhelp.C\cmdlet_write-NcFile.html

 

So it looks like it is doing part of what it is meant to, but it fails to complete and launch the browser.  It also does not specify which file it cannot find.  Is it looking for cmdlet_Show-NcHelp.html ?

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

Thank you this information.  I really hope they release a fix.

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

I think that I've found the cause (but not a solution, unfortunately). In older versions of the PSTK, there are several extra files that aren't contained in the latest versions of the toolkit - at least not my installation. 

2020_01_06_13_00_06_gcc_utl_na_001_Remote_Desktop_Connection.png

So when Show-NcHelp tries to copy all the help files from the module path - C:\Program Files (x86)\NetApp\NetApp Powershell Toolkit\ - to the temp directory and then launch index.html from there, it fails because index.html and the other files don't even exist in the module to begin with. I copied an index.html file from an older version to my new module and was able to launch Show-NcHelp without issue after that. The problem is that index.html references the other HTML files that don't exist, and they wouldn't be updated for 9.7 if they're copied from an older version (and obviously generate errors if clicked on). 

 

I agree, hopefully this can be fixed.

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

 

Is there a place online where the cmdlets are documented we can use in the meantime?

 

I use the browser based help as a reference when working regularly. Having to use get-nchelp at the PS CLI is cumbersome at best.

 

Every system I have installed 9.7 on is exihibiting this behavior where show-nchelp doesn't work.

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

@brandonkit The actual files are contained within the module itself and are just HTML files - my installation is located at C:\Program Files (x86)\NetApp\NetApp PowerShell Toolkit\Modules\DataONTAP\webhelp.C

 

Hope that helps! 

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

A quick searched turned up this TR, although it is a bit old:

https://www.netapp.com/us/media/tr-4475.pdf

 

Re: Powershell Toolkit 9.7 - Show-NcHelp cmdlet error: WARNING: Could not launch browser:

PSTK 9.7.1 was released today and this issue appears to be resolved (at least on the machine that I tested it on). More info and download links here:

 

https://community.netapp.com/t5/Microsoft-Virtualization-Discussions/NetApp-PowerShell-Toolkit-9-7-1-released/td-p/154714

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public