Data Backup and Recovery

Attempting SnapVault updates, getting "ERROR: cannot find storage executor for <filername>"



I am using SnapCreator with SMSQL in combination with VSM and SV updates, and I am struggling to get the SV updates

to work correctly. I tried SC (server & agent) 3.5.0 and 3.6.0c.

What exactly is the nature/cause of this error message ?

The following thread:

points to a problem with multihomed storage systems and SV transfers running over specific interfaces.

While I am working with storage systems with dedicated network interfaces for SM and SV traffic, I am using the hosts

files on the filers to route all SM and SV traffic over specific interfaces. All SM/SV relations are known on both

source and destination by the actual filer hostname when typing "snapmirror/snapvault status".

Also, I tried removing the /etc/hosts entries so that all traffic would run over the public interfaces,

with no difference. Moreover, There is a similar configuration I have running on two other filers

that is working correctly.

The last thing I tried to today was sniffing the traffic on the destination filer: during the backup, there is

not a single packet from the SnapCreator server sent to the destination.

Any ideas why I may be running into this error message ? Thanks in advance,





OK, so I think I found the problem: The SMSQL command-line arguments had to be changed to make sure Generic Naming is used.

So I had to change this:

SMSQL_BACKUP_OPTIONS=-svr 'vwsumsql01' -RetainBackups  15 -lb -bksif -RetainSnapofSnapInfo 16 -trlog -mgmt standard

into this:

SMSQL_BACKUP_OPTIONS=-svr 'vwsumsql01' -RetainBackups  15 -lb -bksif -RetainSnapofSnapInfo 16 -trlog  -gen -mgmt standard

This makes sure that the snapshot name taken bu SMSQL has a fixed name, eg. sqlsnap__vwsumsql01__recent instead of a

timestamp-based name.

Best regards,



Hi Filip,

Sorry for late response I am in bangalore with the entire engineering team for SC so we have been late on answer questions. You are 100% but we need to improve SC so it doesnt allow you to configure timestamp snaps since we dont support this, only _recent.

In SC 3.6 there is a new feature to use external snapshots which is yet another option to do this if you dont want to use plugin or have other SMs or other 3rd party snapshot providers.




A late reply on the topic of external snapshots. Just yesterday I was looking into a way to tie SMO snapshots together with SC, and I remembered that you mentioned this feature in 3.6.0. I now realize that you've implemented this with these two new directives:



which is just beautiful, extremely flexible and exactly what I need! Thanks 🙂