Data Backup and Recovery

MYSQL password Reset


I need to reset the root password for the database for Snapcenter but apparently Netapp isn't actually able to support the Database they wrote their product on.


All they have done is send me the generic MYSQL links which I've tried and failed to have work...probably because they have customized **bleep** the install to boot


I've gone throuhg this and tried the different scripts along with passing the --datadir command to the databases that I think are stored under the C:\programdata folder and it appears to work but nothing happens...I cannot login as root.


I even thought about cheating and using the command line in the registry for the service and just adding in the --init-file to the command line but it tells me that MYSQL57 is not a valid variable.


The command line is something like mysqld --default-file <path> MYSQL57

I am not sure what the MYSQL57 is, unless its an instance name or something...




Changing the mysql root password is a pure mysql side stuff..


did you already tried with


mysqladmin -u root -p password 'yournewpasswd'


or with


mysql> ALTER USER 'root'@'localhost' IDENTIFIED BY 'NewPasswd!';


the thing is that for the secon command you need to connect to mysql before issuing it. So, if you are not able to connect with root anymore....


another thing, does the new password contains some special char like  = " < > etc.. ? i think those char are not supported on mysql side



While I recognise that MYSQL is pure mysql stuff, how can a company build on a product that they leave it to the end user to support themselves.  if they allowed me to put SQL express underneath this, I wouldn't have this problem and we have zero MYSQL experience and the MYSQL implementation is not your plain jane install..they didn't go next,next.finish and done...because they have customized where the data is stored.


The whole point is that I don't know what the actual root password is to login to set it...what we have in password safe doesn't seem to work.  It does have special characters but none of the char are on the blacklist. (I also tried it with a simple word as the password as well with no luck)


here is the service startup command.  I don't understand what the MYSQL57 at the end does though...I initially tired just running the service command and inserting the itint script as an option without any luck.  I thought the MYSQL57 was the actual name of the database to load but I don't think it is.


"C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --defaults-file="C:\ProgramData\NetApp\SnapCenter\MySQL Data\my.ini" MySQL57


I've tried this and it starts up and runs the init script but I still can't login as root


"C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --init-file=c:\\mysql-init.txt --datadir="C:\\ProgramData\\NetApp\\SnapCenter\\MySQL Data\\data" --console


It seems to load and MYSQL is running, however I cannot login as root....any way to log the output of the init script results to see if it worked?


C:\Windows\system32>"C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --init-file=c:\\mysql-init.txt -
:\ProgramData\NetApp\SnapCenter\MySQL Data\Data" --console
2017-12-05T16:13:42.900073Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --exp
lts_for_timestamp server option (see documentation for more details).
2017-12-05T16:13:42.900073Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not
ocation of generated files. Consider setting it to a valid, non-empty path.
2017-12-05T16:13:42.900073Z 0 [Note] C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe (mysqld 5.7.13) s
process 10760 ...
2017-12-05T16:13:42.915655Z 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2017-12-05T16:13:42.915655Z 0 [Note] InnoDB: Uses event mutexes
2017-12-05T16:13:42.915655Z 0 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2017-12-05T16:13:42.915655Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2017-12-05T16:13:42.915655Z 0 [Note] InnoDB: Number of pools: 1
2017-12-05T16:13:42.915655Z 0 [Note] InnoDB: Not using CPU crc32 instructions
2017-12-05T16:13:42.931268Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chun
2017-12-05T16:13:42.946925Z 0 [Note] InnoDB: Completed initialization of buffer pool
2017-12-05T16:13:43.040637Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2017-12-05T16:13:45.712505Z 0 [Warning] InnoDB: Resizing redo log from 2*32768 to 2*3072 pages, LSN=368488005
2017-12-05T16:13:45.853103Z 0 [Warning] InnoDB: Starting to delete and rewrite log files.
2017-12-05T16:13:45.853103Z 0 [Note] InnoDB: Setting log file .\ib_logfile101 size to 48 MB
2017-12-05T16:13:46.087520Z 0 [Note] InnoDB: Setting log file .\ib_logfile1 size to 48 MB
2017-12-05T16:13:46.415603Z 0 [Note] InnoDB: Renaming log file .\ib_logfile101 to .\ib_logfile0
2017-12-05T16:13:46.431235Z 0 [Warning] InnoDB: New log files created, LSN=368488005
2017-12-05T16:13:46.431235Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2017-12-05T16:13:46.446859Z 0 [Note] InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the fi
ease wait ...
2017-12-05T16:13:46.571847Z 0 [Note] InnoDB: File '.\ibtmp1' size is now 12 MB.
2017-12-05T16:13:46.571847Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) a
2017-12-05T16:13:46.587478Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2017-12-05T16:13:46.587478Z 0 [Note] InnoDB: Waiting for purge to start
2017-12-05T16:13:46.650004Z 0 [Note] InnoDB: 5.7.13 started; log sequence number 368487996
2017-12-05T16:13:46.650004Z 0 [Note] InnoDB: Loading buffer pool(s) from C:\ProgramData\NetApp\SnapCenter\MyS
2017-12-05T16:13:46.650004Z 0 [Note] Plugin 'FEDERATED' is disabled.
2017-12-05T16:13:46.696827Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL
not usable without certificate and private key
2017-12-05T16:13:46.712510Z 0 [Note] Server hostname (bind-address): '*'; port: 3306
2017-12-05T16:13:46.712510Z 0 [Note] IPv6 is available.
2017-12-05T16:13:46.712510Z 0 [Note] - '::' resolves to '::';
2017-12-05T16:13:46.712510Z 0 [Note] Server socket created on IP: '::'.
2017-12-05T16:13:47.212435Z 0 [Note] Event Scheduler: Loaded 0 events
2017-12-05T16:13:47.212435Z 0 [Note] Execution of init_file 'c:\\mysql-init.txt' started.
2017-12-05T16:13:47.212435Z 0 [Note] Execution of init_file 'c:\\mysql-init.txt' ended.
2017-12-05T16:13:47.212435Z 0 [Note] C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe: ready for connec
Version: '5.7.13' socket: '' port: 3306 MySQL Community Server (GPL)
2017-12-05T16:13:47.821801Z 0 [Note] InnoDB: Buffer pool(s) load completed at 171205 9:13:47

2017-12-05T16:15:05.773595Z 4 [Note] Access denied for user '=root'@'localhost' (using password: YES)



I've also tried this:


C:\Windows\system32>"C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --skip-grant-tables --datadir="C:\\programdata\\NetApp\\SnapCenter\\MySQL Data\\Data" --console


I can then login as MYSQL


mysql> show databases;
| Database |
| information_schema |
| mysql |
| nsm |
| performance_schema |
| sys |
5 rows in set (0.00 sec)


mysql>use mysql;

Query OK, 0 rows affected (0.02 sec)

mysql> ALTER USER 'root'@'localhost' IDENTIFIED BY 'mynewpassword';
Query OK, 0 rows affected (0.00 sec)


To me, that looks like it worked, but the query didn't actually change anything.