Data Backup and Recovery

NDMP copy of SnapMirror Destination - "Media is write protected"


I Queisced the SnapMirror destination to pause any updates

ndmp-copy /vol/source /vol/destination

Problem is that when I connect/mount these LUNS (for DR test) windows reports "media is write protected"

lun show shows the lun as r/w

if I create a clone of the lun then I still have the same problem

if I create a new LUN inside the same volume it works fine

Any suggestions? Im in the  middle of a DR test and cant progress until I sort this, I logged a call with NetApp support and was told they were in the middle of a shift change and couldnt help me at the minute

any help appreciated!




You are running ndmpcopy on the target?  Have you tried mounting a clone on the target instead?  It sounds like a lun attribute or change needed from windows to change from readonly on the lun object (I remember having to remove the hidden attribute and readonly before.. from fdisk I think - support was able to give us a kb).  But a clone from the target should work... you can then ndmpcopy that clone if you need a copy out elsewhere (assuming the copy of the readonly volume is the issue).

Did support give a workaround or reason?


Support didnt give me anything except "we are in the middle of a shift change maybe someone will call you back but if you get pissed off waitng then call us"

I ran the NDMP copy on the target yep

I tried mounting a clone of the NDMP copy, I have not tried mounting a clone of the snapmirror destination yet, should I try this?

I am on a windows 2008 machine, no fdisk. I can use diskpart. Do you have this KB handy somewhere?


Thank you… yes it was diskpart we used to clear the hidden and readonly flag… but I would clone the mirror instead of copying…then copy if needed. Since you are working with mirrors and copies the good news it won’t affect any production.


Thanks Scott

^ KB for clearing readonly flag

We found the readonly flag to be set to on, we set it to off

After running this and a reboot we still receive media is write protected despite the read only flag showing as off now


ok, in addition to the disk being read only the volume was read only

repeat the steps outline in the KB article but select volume 1,2,3 etc and clear the read only attribute

problem solved

thanks scott, you pointed me in the right direction