Data Backup and Recovery

SC 4.0 for linux 64bit - login inpossible


Today I had downloaded the version 4.0.0c for linux 64 and linux 32 from github. I installed it like this:
gunzip Snap_Creator_Community_Release_4.0.0c-dev_build_10-19-2012-Server_Linux64.tar.gz
cd /opt
tar xvf /home/rainer/Snap_Creator_Community_Release_4.0.0c-dev_build_10-19-2012-Server_Linux64.tar
cd scServer4.0.0c
chmod 755 snapcreator

./snapcreator --setup
modified the variable SNAPCREATOR_PATH within the file bin/scServer to SNAPCREATOR_PATH=/opt/scServer4.0.0c

chmod 755 bin/scServer

bin/scServer start

Then I go with my browser (firefox, IE) to http://:8080 and tried to login. But I always get "Invalid username/password".
I tired this with several usernames and passwords but with the same result.

What is the right procedure to install this version?

We use CentOS 6.2 64bit





When you ran: snapcreator --setup

It should have automatically updated the SNAPCREATOR_PATH for you.

The setup also should have prompted you for your username and password.

As of SC 4.0 the URL has been updated to:http://<hostname or IP>:8080/ui/

If you are getting a GUI at :8080 then you may still be running an old instance of SC somewhere.

Otherwise your steps look correct.

Please keep in mind that this is not the full community release - it was a QA release from some time ago.

That may be why you needed to manually update the SNAPCREATOR_PATH - this will not be required in the community release.

Hope this helps,




Please refer the engine/etc/ file

You will see an encrypted password -

Please let me know if you use that password whether your GUI lets you in.

Alternatively, you may try to change the password in the SNAPCREATOR_PASS and see if that works.

I tried this in the lab myself, and I am getting the same results as you.

I have reached out to the developers and will keep you posted with an update.

Siva Ramanathan

Snapcreator Community Moderator