Data Backup and Recovery

SnapCenter 4.0 Can’t remove Netapp plugin for vSphere in vCenter 6.5


I got an issue where I can’t remove the plugin. We have two linked vCenter 6.5 and where I upgraded SnapCenter from 3.0.1 to 4.0 and this went well on one vCenter, not the other. Struggled with this and managed at last to upgrade vSphere plugin but lost the contact to it from SnapCenter.  Tried then to reinstall from SnapCenter, but got “Adding vCenter is not supported because another SnapCenter Plug-in for VMware vSphere host is already registered with vCenter” So then I tried to remove the plugin in MOB. In MOB there is none NetApp plugin, still the plugin is visible in vSphere WEB client and enabled. In the vSphere WEB client the setting /connector is grey out, got red frames when trying to enter credentials.


Anyone who can help me here?




Ok, all possibilities shall be tried. So I tried to install  SnapCenter_Windows_vSphere_Plugin direkly at the SCV server, and it worked. Then I restarted install from SnapCenter, got a fault, warning, choose next anyway and the job resulted in a OK status. Still fault at the vCenter, så I rebooted that one, and no is everyting OK, big smile.


I hope this can be useful for anyone else ;D

Have a nice weekend ;D




     i'm glad that its working for you now.  i was going to suggest restarting the vCenter service or rebooting of the vCenter server, but it looks like you have already tried that and that made things work again 🙂