Data Backup and Recovery

SnapCenter Cannot See vSphere Policies or Resource Groups


Hi all,


I have deployed SnapCenter 3.0.1 along with vCenter 6.5 and ESXi 6.5. I can see the SnapCenter Plug-in for VMware vSphere in the vSphere Web Client and can create backup policies through it. I see the policies I've created listed in the vSphere Web Client.


However, when I log in to the SnapCenter Server (with the same Domain account that I created the Policies as via vSphere, and the same account also has the SnapCenterAdmin role within SnapCenter) I go to the Settings > Policies section and it says "There is no match for your search or data is not available."


On the same page there is a drop-down arrow in the menu along the top next to the words "File Systems". If I click that the only option is File Systems. I was expecting that maybe I would see vSphere listed there but I don't.


If I jump back to the vSphere Web Client I can use the SnapCenter Plug-in to create a Resource Group and pick one or more of my existing policies to use. It says the Resource Group was created, but if I refresh the Resource Groups pane in the vSphere Web Client, no Resource Groups are listed. The page is empty.


Similarly if I jump back to SnapCenter and go to the Resources section, it too shows as completely empty.


I've tried going in to Settings > User Access and assigning my user account access to all types but the screens still show as empty.


Interestingly though, when I go to Settings > User Access and I change the Asset drop-down to "Policy" I see 3 default policies listed and also the policies that I created through the vSphere Web Client. My user account is listed as having access to that policy. However, when I visit the policies section I don't see any of them.


I'm thinking this is something simple, with how I've applied permissions or something along those lines.


Anyone come across this one?







I deploy Snapcenter 4.0. 


I see policie, but i don't see ressource group.


Have you found a solution?


Best Regards


I seen everything in Vsphere webclient page->Home->Snapcenter Plugin for Vmware Vsphere.

Like resource group,Policies.


I am experiencing this now.  Deployed fresh install of SnapCenter 4.0 / vCenter 6.5 U2 / Ontap 9.1P9.


Created a Resource Group and it was visible for a few days, the backup still runs as scheduled - but  the Resource Group is no longer visible (it is/was the only one I created).  I just created a TEST Resource Group and it too is not visible.

I have three (3) linked vCenters in this environment so regardless of which vSphere web client I log into (yes, it really shouldn't matter but it was worth a shot) I cannot see my (2) Resource Groups.


Another twist...  I was once able to see VSC in my vSphere menu but now it is not there when I log into one of the three web clients.  I UnRegister/Register the VSC server with the vcenter and VSC is still not a menu option for the one vSphere interface.




Hi Chris,

For vsphere backups, all resource group and Policies management is through vsphere webclient only. not from snapcenter server. Snapcenter you can use only for adding new SCV host(vsphere) and storage systems only.


So apparently I had a number of permissions issues going on here.  I did a full "rewind" and re-configured the registrastions to vCenter with consistent RunAs credentials, FQDN for all (as as spelled out in the documentation) and just plain started the configuration over and I'm back on track.... RTFM works again!!