Data Backup and Recovery

SnapCreator Xen configuration and issues


Configuration of backup using SnapCreator Framework with the XEN plugin.


I'm writing this so that it might help others avoid the same issues I have encountered. Not that I'm completely done but documenting the progress so far. If you have other configurations that work better then just add with a comment for reference.


The documentation is a little basic on how to use the XEN plugin.


Setup for reference.

Xen 6.5

Clustered ONTAP 8.3.2

SnapCreator 4.3 running on Windows 2012R2.

XEN administration installed on the same server as SnapCreator Framework. (xe.exe)


SnapVault to secondary site


Experienced issues.

  • If the server name has spaces in the name the listing during backup fails. The listing in the gui works.
  • The agent timeout of the default 600 seconds was far too short. Had to increase it to 1800 seconds
  • The SnapCreator server is a VM. If it is quiesced then xe stops and the workflow dies. Removing this VM from the storagepool solved this.
  • Had to set APP_IGNORE_ERROR=Y in order to avoid the job to fail just because a single VM could not be quiesced.
  • Emailing the results - good backup and bad backup.

For email this configuration worked. The issue was where the single apostrophes was placed. Fine post regarding email here:



Still having an issue with unquiescing the VM's and getting the SnapVault update triggered without getting errors.

If you have info regarding getting this into a fool proof state pls enlight me.













Thanks for sharing this information.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.





i´m trying to use it with Snapmanager 4.3 and FC on Xenserver 7.0. 



But it seams it don´t discovers the Storage.



Error in XEN RPC call failed with following error



Failed to get the VM record information of VM

Discovering the VMs failed for HOST :


I have installed a Windows 2012 R2 Server with Snapmanager and Xencenter on it.


Did you tried Xenserver 7.0 already ?