Data Backup and Recovery

sqlio results local disk vs netapp


Just to test, I ran SQLIO

on a windows 2008 box (DL785) local disk (4x300G, RAID 10)  vs a Netapp aggregate of 56 disks. Filer is running, this is a FC LUN.  Aggregate is not really that loaded.

Surprisingly to me, the results show the C drive to be faster.  I know there are various ways to tweak SQLIO but I still find this odd.  Any suggestions would be appreciated:

SQLIO: 1 thread reading for 30 secs using 2KB IOs over 128KB stripes with 64 IOs per run:

Local C:\     [sqlio -dC]

IOs/sec:  5844.79
MBs/sec:    11.41

Netapp F:\    [sqlio -dF]

IOs/sec: 2547.88
MBs/sec:     4.97

SQLIO: 1 thread writing for 30 secs using 2KB IOs over 128KB stripes with 64 IOs per run:

Local C:\    [sqlio -kW -dC]

IOs/sec: 10116.73
MBs/sec:    19.75

Netapp F:\    [sqlio -kW -dF]

IOs/sec:  1895.42
MBs/sec:     3.70



Have you check for partition alignment, LUN type mismatch, FC frame errors, other user-level errors?

This discrepancy is shocking and can only be some unoptimized settings.


What type of disk is the 56 disk aggregate, its RG size?  What is you measure of "not really that loaded" ?  Are disk queue lengths and latency response high in perfmon?  Do you have performance advisor on this aggregate? Are storage latencies high?


Aggregate is a 56 disk aggregate, with standard 16 disk raid groups, total aggregate iops in DFM never exceeds 500-1000.  I have to look at all of the other stuff



What speed of disk?


What HBA(s) are you using? How about drivers? Thanks,  -Wei


These are Emulex HBA's, with Netapp Host utilities, Snapdrive 6 and MPIO.  Disks on the filer are 15k rpm


Can you provide the Emulex HBA model #? Also, what driver are you using? Version #? How about driver parameter, such as queue depth?




Has your problem been solved? I think we have Thread Link : 13413. Can you share your thoughts?

We had an issue like this at the back end of 2009.  It was caused by a 'rogue' HBA driver that windows had download from the server vender.  Replaced with the NetApp drive and issue resolved.

Hope it helps


Although we don't have HBA iSCSI NICs, this might be a NIC driver issue (or setting). We're using Broadcom NetXtreme II BCM5709 cards. Had anyone problems with those?

-- edit--

As there are many models with this chipset, I'll be more precise - this is a default NIC implemented in IBM x3550M3 (2 port) + doughter card (2 port)