Data Infrastructure Management Software Discussions

Upgraded WFA 4.0 to 4.2 and custom datasource failed

I just upgraded from WFA 4.0 to 4.2 and a custom datasource that was working started failing.


The file is in utf8 bom format and nothing changed since the upgrade with the datasource.


This is the error when the acquisition is done. I also tried a refresh schema and deleting the csv files and it errors out the same way.



Invalid utf8 character string: 'FG'



I also tried to delete the datasource and recreate it and still same error.


I looked through the file and it's delimited properly.



More Logs

2018-04-26 20:00:00,274 ERROR [com.netapp.wfa.cache.job.CacheJobExecutorImpl] (Thread-146 (HornetQ-client-global-threads-1768097467)) Failed running cache job - databases were dumped to D:\Program Files\NetApp\WFA\jboss\standalone\tmp\wfa\localhost-wfa_staging#tiaa_domain-1639129095459153457.dump: javax.ejb.EJBException: com.netapp.wfa.util.SqlShellException: <localhost> Failed to load from 'D:\Program Files\NetApp\WFA\jboss\standalone\tmp\wfa\domain_groups.csv' into wfa_staging.tiaa_domain_domain_groups



Caused by: org.mariadb.jdbc.internal.common.QueryException: Invalid utf8 character string: 'FG'

Re: Upgraded WFA 4.0 to 4.2 and custom datasource failed


Problem is because of mysql. It may be because of more stringent checks introduced in mysql.


For experiment, you can downgrade mysql as is told in the link.

Then we will be able to pin point the problem.



View solution in original post

Re: Upgraded WFA 4.0 to 4.2 and custom datasource failed

Mirko answered this question privately.



Cloud Volumes ONTAP
Review Banner
All Community Forums