E-Series, SANtricity and Related Plug-ins Discussions

Highlighted

Assigning LUN to host group different than individual host? I'm getting errors on the hosts.

I have several LUNs assigned to individual hosts that I would like to reassign to several hosts on the recommendation of my backup vendor.  I created a host group, moved the hosts to that group, and reassigned the LUNs to the group.  I can see the storage on all the hosts, but when I start using it, I get errors like the ones below.  I've assigned LUNs to hosts many times with no problems, but this is the first time I've tried a group.  Is the process different?  Is there addition configuration or software needed on the hosts to use the shared LUNs safely?  Your help is appreciated as this is affecting my backups right now.

 

cat.png

cor.png

4 REPLIES 4
Highlighted

Re: Assigning LUN to host group different than individual host? I'm getting errors on the hosts.

Is this a new setup and these LUNS don't have any data written on them ? If yes, Please go ahead and delete the LUNS and recreate and assign them to the host group again...

If NO, May i know what are the steps taken before unmapping it from a individual host groups and mapping it to another host group ?

1. Stop any application on the windows server hosted on these LUNS (Make sure no transactions on the LUNS)

2. Unmap the lun from current host group and map to new group

3. From Windows disk management run a scan/refresh

4.Start the service/application if any

 

Highlighted

Re: Assigning LUN to host group different than individual host? I'm getting errors on the hosts.

These are existing LUNs with data on them.  I did exactly as you said :

 

Stopped application

Mapped LUN to group

Refreshed disks on hosts

Started application

 

All appeared good at first, but then I noticed errors in the backup jobs.  I tested by trying to create a new folder on the volumes, and it would give the errors I provided earlier.

Highlighted

Re: Assigning LUN to host group different than individual host? I'm getting errors on the hosts.

Are you using Clustered Shared Volumes?  If not, you will get data corruption without some sort of access control on the hosts.

Highlighted

Re: Assigning LUN to host group different than individual host? I'm getting errors on the hosts.

I just learned that this morning.  These aren't clustered.  They all serve just one application with one server having the write capability and others read-only.  I thought that would be the control I need, but it sounds like no.  I don't think I can provide the LUNs to the host group with the affect I wanted.

Try the NEW Knowledgebase!
NetApp KB Site
Forums