General Discussion

AIQUM 9.8 problem with MYSQL

anton_okan

Hi all!

 

Could you please help to resolve

I've a problem with install  netapp-um-9.8-el8.x86_64.rpm

 

[root@localhost ~]# yum install netapp-um-9.8-el8.x86_64.rpm
Last metadata expiration check: 0:49:10 ago on Thu 21 Jan 2021 04:53:44 AM EST.
Error:
Problem: package netapp-um-9.8-2012111600.el8.x86_64 requires mysql-community-server >= 8.0.17, but none of the providers can be installed
- conflicting requests
- package mysql-community-server-8.0.17-1.el8.x86_64 is filtered out by modular filtering
- package mysql-community-server-8.0.18-1.el8.x86_64 is filtered out by modular filtering
- package mysql-community-server-8.0.19-1.el8.x86_64 is filtered out by modular filtering
- package mysql-community-server-8.0.20-1.el8.x86_64 is filtered out by modular filtering
- package mysql-community-server-8.0.21-1.el8.x86_64 is filtered out by modular filtering
- package mysql-community-server-8.0.22-1.el8.x86_64 is filtered out by modular filtering
- package mysql-community-server-8.0.23-1.el8.x86_64 is filtered out by exclude filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@localhost ~]#

 

On download page I see that:

Important: On Linux platforms, on your configured MySQL 8.0.x repository, disable any MySQL minor versions other than MySQL 8.0.21 (for example 8.0.22) by running the following steps:

1. Open the /etc/yum.conf or /etc/yum/yum.conf file.

2. Add the exclude variable for MySQL, along with the name of the package and version: exclude=mysql-community*8.0.22*

 

My file  /etc/yum.conf look like 

exclude=mysql-community*8.0.17*
exclude=mysql-community*8.0.18*
exclude=mysql-community*8.0.19*
exclude=mysql-community*8.0.20*
exclude=mysql-community*8.0.22*
exclude=mysql-community*8.0.23*

 

[root@localhost ~]# rpm -qa | grep -i mysql
mysql80-community-release-el8-1.noarch
[root@localhost ~]#

 

Someone have this problem too?

1 REPLY 1

Re: AIQUM 9.8 problem with MYSQL

anton_okan

it resolve

 

first 

My file  /etc/yum.conf look like:

[main]
gpgcheck=1
installonly_limit=3
clean_requirements_on_remove=True
best=True
skip_if_unavailable=False
exclude=mysql-community*8.0.17* mysql-community*8.0.18* mysql-community*8.0.19* mysql-community*8.0.20* mysql-community*8.0.22* mysql-community*8.0.23*

 

Second need:

yum module disable mysql
yum install mysql-community-server

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public