General Discussion

FAS2220 8.1.4P10 NFS retain permission when files create in Windows File Explorer

Hi,

 

We just created a volume with UNIX style permission. Under it, we create 2 qtrees with UNIX permission as well.

These 2 qtrees we are using primary for NFS mounted on Linux machine.

 

(1) 

We migrate some of the some existing local mount disk on the Linux machine to these 2 qtrees mounted.

eg.

/data/123 mounted local disk directory migrate to NetappFiler:/vol/NFS_Share1_vol/filedata1_qtr

/data/456 mounted local disk directory migrate to NetappFiler:/vol/NFS_Share1_vol/filedata2_qtr

 

(Note: /data/123 and /data/456 are export as NFS to other linux workstation to access)

 

All the permission was migrated as-is and intact.

So with this, other linux machine can now access to this NetApp qtree directly instead of going through the Linux machine.

 

 

(2)

On the current Linux machine, we also setup the above (1) local disk directory using samba so that user can access with file explorer on their windows client.

eg.

/data/123 directory. default to user abc (shared as 123)

/data/456 directory. default to user fgh (shared as 456)

 

So when user access the samba shared using explorer they can maintain whatever file they wanted.

If they access to eg 123 and create a new file, the default permission will be abc:abc

If they access to eg 456 and create a new file, the default permission will be fgh:fgh

 

We tried to implement the same setup pn above (2) on the NetApp level.

We tried to map all user *\* ==> abc in the usermap.cfg file.

 

Then we open the window client file explorer and tried to access to 123 and create the a new powerpoint file.

However the permission did not follow the user abc. It is created as root:bin instead.

 

-rwxrwxr-x 1 root        bin         0 Jul 18 14:56 New Microsoft PowerPoint Presentation.pptx

 

The permission for directory under unix is abc:abc.

 

drwxrwxr-x 2 abc abc 4096 Jul 18 14:56 new

 

Goal

1) So what we want to achive here is that when any user use windows file explorer to create files under the directory new, it should take the local unix permission abc:abc.

 

Any idea how we can make this happen ??

 

 

 

 

Forums