Legacy Product Discussions

Fas250 - No disks show


I recently picked up two fully loaded extra shelfs (DS14/MK2) and as I had a spare FAS250 head I decided I might as well test them out good.

However, both shelfs report:

slot 0: FC Host Adapter 0b (Dual-channel, QLogic 2312 rev. 2, 32-bit, L- port, <OFFLINE (hard)>)

I have two other of these shelfs that are fine and the FAS250 worked with those before I put them in production, its a spare 250 too. One shelf I'd suspect the shelf, but not both. Is there something internal to the shelfs that I might need to do? Both shelfs were used in a multi-shelf environment. And I've set them to ID 1 as well.

Is a terminator absoultely required for the FC channel to work? My two production system have no terminators and they work fine, but

I also read something about RoHS vs non-RoHS and for sure a copper based FC has to be terminated. Both extra shelves are non-RoHS.

Going into Maint 4a always gives no disks found.

Other commands:

*> disk show -v
Warning: Software-based disk ownership is not currently being used on this system.
Local System ID: XXXXXXXXX

disk show: No disks attached to system.

On boot up:

NetApp Release 7.3.2: Thu Oct 15 04:24:11 PDT 2009
Copyright (c) 1992-2009 NetApp.
Starting boot on Wed Dec 31 23:59:58 GMT 1969
Thu Jan  1 00:00:27 GMT [nvram.battery.state:info]: The NVRAM battery is current
ly ON.
This boot is of OS version: NetApp Release 7.3.2.
The last time this filer booted, it used OS version: <unknown>.
The WAFL/RAID versions of the previously booted OS are unknown.
If you choose a boot option other than Maintenance mode or
Initialize disks, the file system of your filer might be upgraded
to a new version of the OS.
If you do not want to risk having your file system upgraded, choose
Maintenance mode or reboot using the correct OS version.

(1)  Normal boot.
(2)  Boot without /etc/rc.
(3)  Change password.
(4)  Initialize all disks.
(4a) Same as option 4, but create a flexible root volume.
(5)  Maintenance mode boot.

Selection (1-5)? 4a
NVLOG: UNKNOWN nvram magic value (0x1be81000)

WARNING: nvlog_test: Unexpected nvlog contents.  Will discard contents of nvlog,

PANIC: This system has no disks, and thus no file system can be created on it in
process rc on release NetApp Release 7.3.2 on Thu Jan  1 00:00:56 GMT 1970


*> sysconfig -v
Thu Jan  1 00:00:55 GMT [shelf.config.unknown:info]: System storage configuratio
n is unknown
        NetApp Release 7.3.2: Thu Oct 15 04:24:11 PDT 2009
        System ID:
        System Serial Number:
        System Rev: J0
        System Storage Configuration: Unknown
        System ACP Connectivity: No Connectivity
        slot 0: System Board 600 MHz (TSANTSA E0)
                Model Name:         FAS250
                Part Number:        110-00016 <-- Non-RoHS
                Revision:           E0
                Serial Number:     
                Firmware release:   CFE 1.2.0
                Processors:         1
                Processor revision: B2
                Processor type:     1250
                Memory Size:        510 MB
                NVMEM Size:         64 MB of Main Memory Used
        slot 0: FC Host Adapter 0b (Dual-channel, QLogic 2312 rev. 2, 32-bit, L-
port, <OFFLINE (hard)>)
                Firmware rev:   3.3.27
                Host Loop Id:   0       FC Node Name:   5:00a:098000:0031f2
                Cacheline size: 8       FC Packet size: 2048
                SRAM parity:    Yes     External GBIC:  No
                Link Data Rate: 1 Gbit
        slot 0: FC Host Adapter 0c (Dual-channel, QLogic 2312 rev. 2, 32-bit, L-
port, <OFFLINE (hard)>)
                Firmware rev:   3.3.27
                Host Loop Id:   0       FC Node Name:   5:00a:098100:0031f2
                Cacheline size: 8       FC Packet size: 2048
                SRAM parity:    Yes     External GBIC:  No
                Link Data Rate: 1 Gbit
        slot 0: Dual SB1250-Gigabit Ethernet Controller
                Device Type:        BCM1250
                e0a MAC Address:    00:a0:98:01:e3:4f (auto-unknown-cfg_down)
                e0b MAC Address:    00:a0:98:01:e3:50 (auto-unknown-cfg_down)
        slot 0: ATA/IDE Adapter 0a (0x00000000000001f0)
                0a.0                 SanDisk  SDCFB-256-911B   HDX 2.15 245MB 51
2B/sect (109320B2405W2954)

Any help or suggestions greatly appreciated!




One more thing, the first FAS250's only did 1Gbit FC, IIRC... Also try setting the shelf speed down to 1Gb/s and see if that helps...


The 250 doesn't even let you have the switch in 2gb position to start without a core-dump. Already set to 1gb.


However, after more experimentation, which led to even more obfuscation!

When the head is in the top slot, disk 13 takes 0b channel down. When the disk is in the bottom slot, disk 0 takes 0b channel down!

Doesn't matter with I have the other slot empty, or with an esh2 (for termination) or and esh module.

So which slot the head is in, causes the correspoindig disk slot to get the line break in the fiber channel and take it down. Very strange and it does this on

both ds14/mk2 shelfs. I have another ds14/mk2 in production with a 250 head in it and did not see that on initial testing and all 14 drives are in it.


It's not a matter of disk assignment. A "storage show disks" works fine when the FC is up. The 250 works with both hardware and software assignment.


If I remember correctly, the FAS250 couldn't have more than 14 disks.  The FC link is there for tape backup.  There should be no ESH module in the shelf, just the "head" in the "A" slot.  FAS250 systems always came with a "blind" module that just filled slot B.

In any case, it seems like your disks need to be assigned to the filer, but I can't remember for sure. The FAS270 always used disk ownership.

After you remove the ESH module from slot B, try booting into maintenance mode ("5") and see if you can see the disks there.


Progress!  After swapping things around, putting in an esh card vs. esh2 card, etc.... Still not luck. However, I think decided to remove all the drives and see what happens.

0b stayed up!

Popping a drive in slot 0 and we get:

Thu Jan  1 00:08:06 GMT [fci.link.break:error]: Link break detected on Fibre Channel adapter 0b.
Thu Jan  1 00:05:51 GMT [fci.link.error:error]: Could not recover link on Fibre Channel adapter 0b after 30 seconds. Offlining the adapter.
Thu Jan  1 00:05:51 GMT [fci.adapter.offline:info]: Fibre Channel adapter 0b is now offline.

Note: This ONLY happens when a drive (any drive) is put into slot 0! I was able to populate the chassis from 1-13 and now show 13 drives online and 4a is building me a file system!

But why???? What is unique or configured in this ds14/mk2 chassis (both of them) that slot 0 brings down 0b? I suspect something with clustering maybe? Is there some switch or config I need to do to the chassis to fix this? At least I've confirmed it's not my spare head....


------------ ----- -------- ---------------- ---- -------------------- -- -------------- --
0b.28        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0SNDA             ff  281442151 520  N
0b.27        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X2GYXA             ff  281442151 520  N
0b.29        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0BXDA             ff  281442151 520  N
0b.18        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0SGTA             ff  281442151 520  N
0b.17        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0Z3AA             ff  281442151 520  N
0b.19        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0R82A             ff  281442151 520  N
0b.20        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X1AJNA             ff  281442151 520  N
0b.21        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0S4XA             ff  281442151 520  N
0b.22        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X2DXPA             ff  281442151 520  N
0b.26        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0SHBA             ff  281442151 520  N
0b.25        FC:A  NETAPP   X274_S10K7146F10 NA07 3KS1QET600007532D5P8 ff  280790184 520  N
0b.24        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X1XBWA             ff  281442151 520  N
0b.23        FC:A  NETAPP   X274_HPYTA146F10 NA04 V5X0G44A             ff  281442151 520  N
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.