Legacy Product Discussions

vFiler migrate errors on CIFS not licenced for destination

fletch2007
views-count 996 Views

We don't use CIFS, but by default the vFilers we created have the CIFS protocol checked (along with iscsi and rsh) when all we want is NFS.

Q: How do I disable the CIFS, iscsi, rsh protocols FROM THE COMMAND LINE to allow the vFiler migrate to proceed?

I did it through the FilerView MultiStore->Manage wizard on a test vFiler, but the wizard touches exports and I can not risk that in production.

From the audit logs, it looks like the wizard is updating a registry setting? - how can I do this from the command line?

Fri Oct 15 15:51:50 PDT [netapp-02: registry_control:debug]: root: MODIFY:options.vfconfig.vm64-vf-01.cifs_disabled:1
thanks
3 REPLIES 3

Re: vFiler migrate errors on CIFS not licenced for destination

ekashpureff
views-count 997 Views

Cifs:

Edit 'cifs start' out of /etc/rc

cifs terminate

options rsh.enable off

options iscsi.enable off

Cifs and iscsi:

license delete cifs/iscsi

At your service,

Eugene Kashpureff

Re: vFiler migrate errors on CIFS not licenced for destination

rshiva
views-count 997 Views

Hi there,

Have you tried the "vfiler disallow" command on ONTAP? The vfiler allow will list the enabled protocols of the vfilers on a storage system.

Thanks and regards

Shiva Raja

View solution in original post

Re: vFiler migrate errors on CIFS not licenced for destination

fletch2007
views-count 997 Views

vfiler disallow did the trick!

thanks

PS: the other method had been suggested outside the vfiler context

G2 Review Banner
All Community Forums
Public