Microsoft Virtualization Discussions

Application requires powershell 3.0 or above

FerdiG

Hi,

 

While trying to install NetApp_PowerShell_Toolkit_4.2.0 on a new install Windows 10 . keep on getting "the application requires powershell 3.0  or above, Windows 10 will not install a lower version of powershel, haven't been able to go past this. Any advice?

2 REPLIES 2

mbeattie

Hi,

 

I've not tried it on Windows 10 yet however you could try installing it on another system and simply copying the "DataONTAP" module folder (EG "C:\Program Files (x86)\NetApp\Data ONTAP PowerShell Toolkit\DataONTAP") to the "Modules" folder within your system's powershell modules directory. EG "C:\Windows\System32\WindowsPowerShell\v1.0\Modules\DataONTAP"

In "theory" you should then be able to do an "Import-Module -Name DataONTAP" within your powershell session.

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Aparajita

Hi FerdiG,

 

Would it be possible to run the installer from an administrator account/with admin privileges?

 

Open an Administrative Command Prompt -> Navigate to the msi folder -> run the command NetAppPowerShellToolkit.msi [where NetAppPowerShellToolkit.msi is the full name of your downloaded installer] - this should resolve the PowerShell version issue. The installer tries reading a registry value to determine is PowerShell 3.0+ is installed and reading registry is not allowed without admin priviledges. I suspect that is the problem ...

 

Hope this helps,

Aparajita

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public