Microsoft Virtualization Discussions

Fast forward to 11/2020 I am getting "Connect-NaController : API invoke failed".

shead2

There are threads from 2016 but I doubt are relevent in my case (2020) Help!

PS c:\ Connect-NaController -Name nascf002 -Credential admin -HTTPS
***Connect-NaController : API invoke failed.***
At line:1 char:1
+ Connect-NaController -Name nascf002 -Credential admin -HTTPS
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidResult: (nascf002:NaController) [Connect-NaController], NaException
+ FullyQualifiedErrorId : HttpConnectionFailed,DataONTAP.PowerShell.SDK.ConnectNaController

 

My Settings:

External Web Services: true
HTTP Port: 80
HTTPS Port: 443
Protocol Status: online
Per Address Limit: 80
Wait Queue Capacity: 192
HTTP Enabled: false
CSRF Protection Enabled: true
Maximum Number of Concurrent CSRF Tokens: 500
CSRF Token Idle Timeout (Seconds): 900
CSRF Token Absolute Timeout (Seconds): 0

 

running Powershell version:  Version  5.1.14393.3471

running NetApp Took kit is v9.8.0

running Windows 2016  [Version 10.0.14393]

 

 

1 ACCEPTED SOLUTION

Ontapforrum

Are you connecting to 'cDOT' ? likely so b'cos the user in your command is 'admin'.

For cDOT use : Connect-NcController

 

Note: Connect-NaController is the 7-mode equivalent.

View solution in original post

1 REPLY 1

Ontapforrum

Are you connecting to 'cDOT' ? likely so b'cos the user in your command is 'admin'.

For cDOT use : Connect-NcController

 

Note: Connect-NaController is the 7-mode equivalent.

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public