Microsoft Virtualization Discussions

Get-NCQuotaReport results doesn't match "quota report show"

Hello Community,

 

I'm using PowerShell commandlets to get the quota report from a NetApp Cluster.

 

I have one SVM for home directories. There is one share with a lot of subfolders for each user. When creating the folder, we create a quota for the user. There's although a default quota. After creating the quota I run Start-NcQuotaResize. The quota appears afterwards correct in the quota report.

 

But when I delete a directory and the quota rule and run a quota resize, the "old" entry still appears in the PowerShell quota report.

 

When I run the following command in the ssh-shell the result is "There are no entries matching your query."

 

quota report show -vserver svm_home -quota-target AD\user

When I run the follwing command by PowerShell, I still get a result:

 

get-ncquotareport -QuotaTarget AD\user -Vserver svm_home

The ssh-command takes in our environment more than 10 minutes to finish, the Powershell command takes about 3 seconds. So the PowerShell seems to use a data source for the quota report which is different from the data source the ssh command is using. The PowerShell data source seems to be very fast, but outdated.

 

Any ideas ?

 

TIA and regards,

 

Ralf

Forums