Microsoft Virtualization Discussions

Get-NaCifsShare returns only limited info


When I run the Get-NaCifsShare cmdlet, it returns only MountPoint, ShareName, and Description.  I don't get the rest of the paramaters as descibed in the documentation (e.g.: IsVscan, IsVscanread, etc).  I get this behavior with or without a share, and with or without the "verbose" parameter.  Am I missing something?

I'm running Data ONTAP 7.3.3P5 and Toolkit version 1.2.





Hi, Glenn.  You're not missing anything.  The Toolkit will display all values returned by Data ONTAP, but in your case (and mine) it appears the controller isn't returning the other fields (which are marked as optional in the ManageONTAP SDK, indicating they may not always be present).


Thanks, Clinton, for the quick response. Naturally, I'd like to see the attributes returned so I can automate the management tasks related to shares.

I'm just getting started with the toolkit and really like what I've seen so far......

Thanks again,




Problem solved.  If you pipe the output of get-nacifsshare to the "format-list" cmdlet, all the properties are displayed (at least on my controller).

For example: get-nacifsshare -share <ShareName> apps | format-list.

Further, you can strip out only the properties you want from the list with: get-nacifsshare -share <ShareName> | format-list -property MountPoint,IsVsvan

Thanks again for the help,



Thanks, Glenn, now I understand what you were asking.  Yes, the data formatters in Toolkit 1.2 limit the data to best fit in tabular form.  Even the list formats are somewhat truncated in many cases by the formatters.  To see absolutely everything, use Format-List *

This is covered in more detail in the Toolkit 1.2 tips document.  In this example, it's clear ONTAP is not returning any of the optional data fields.

PS C:\> Get-NaCifsShare HOME | fl *

Caching                          :
Description                      : Default Share
DirUmask                         :
FileUmask                        :
Forcegroup                       :
IsSymlinkStrictSecurity          :
IsVolOffline                     :
IsVscan                          :
IsVscanread                      :
IsWidelink                       :
Maxusers                         :
MountPoint                       : /vol/vol0/home
ShareName                        : HOME
Umask                            :
DirUmaskSpecified                : False
FileUmaskSpecified               : False
IsSymlinkStrictSecuritySpecified : False
IsVolOfflineSpecified            : False
IsVscanSpecified                 : False
IsVscanreadSpecified             : False
IsWidelinkSpecified              : False
MaxusersSpecified                : False
UmaskSpecified                   : False


Guys, how about to list *>cifs shares as a remote connection?  Its possible with some other script or command?

That show me  Name                 Mount Point                             Description

                         ------                    ----------------                               ------------

                        ShareName         /vol/test/sharename                  User1

                                                       Dev\User1  / Full Control                                

In this case I need the user permissions Information as you can see above remarked. That is possible?