Microsoft Virtualization Discussions

Get-NaDiskOwnership bug

hland

I believe there is a bug in the Get-NaDiskOwnership cmdlet. The documentation says:

-OwnershipType <String>

        Possible values are:

       

        'all' which will list all disks.

        'unowned' which will list all disks without owners.

        'owned' which will list all disks with owners.

        'unknown' which will list all disks with unknown owners.

        'visible' which will list all disks belonging to the local and partner filer.

However, a Get-NaDiskOwner -OwnershipType 'unknown' returns an error: "Get-NaDiskOwner : Invalid ownership-type unknown"

All other ownership types work fine.

This is on PoSh Toolkit version 3.0. Could somebody please confirm if this is a bug?

Thanks

Hendrik

1 ACCEPTED SOLUTION

beam

This looks like a documentation issue.  From what I can tell, 'unknown' was a valid value for ownership-type, but was never intended to be used and was eventually removed.  The help documentation for Get-NaDiskOwner will be updated.

-Steven

View solution in original post

1 REPLY 1

beam

This looks like a documentation issue.  From what I can tell, 'unknown' was a valid value for ownership-type, but was never intended to be used and was eventually removed.  The help documentation for Get-NaDiskOwner will be updated.

-Steven

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public