Microsoft Virtualization Discussions

Set-NaVolLanguage Cmdlet Fails when .UTF-8 is appended "Cannot make this change from rsh or ZAPI"

wmorlett

I am having an issue changing the volume language on a volume with the Set-NaVolLanguage Cmdlet when appending UTF-8.  The command fails stating "Cannot make this change from rsh or via ZAPI."  If I do not append the language locale with UTF-8 the command succeeds.  Is there a way to get the command to work when appending .UTF-8? 

Set-NaVolLanguage -Name $volume -Language "en_US.UTF-8" -WarningAction SilentlyContinue

3 REPLIES 3

wmulhair1

What version of Ontap are you running?  I'm not sure en_US.UTF-8 is available as a language option prior to 8.2.

rmatsumoto

I think all the ones we’re interested in are on 8.1.x and on 7-mode. It is an option. We have some as en_US.UTF-8 already. We just didn’t have the root vol set as it to start so some NAS volumes don’t have that language code.

rmatsumoto

I ran into this problem as well, although if I had to guess, this is not a powershell/toolkit-specific problem.  I tried the old fashioned "vol lang volname en_US.UTF-8" approach over ssh using DFM and got the exact same message.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public