Microsoft Virtualization Discussions

Get-NaHostDisk not returning HostDrivePath


I have an intermittent issue where the Get-NaHostDisk cmdlet will not return all the correct information on both 1.6 and 1.7 versions of the module.

For example, in the screenshot below no HostDrivePath's are returned and for Disk 7 no Controller Path is returned despite this being a LUN.

We use Get-NaHostDisk when cleaning up flexcloned database volumes to get the vol path and ensure it is offlined and deleted. At the moment this sometimes fails due to incomplete information and we have to manually offline/destroy the volume once the disk has been removed.

sdcli disk list correctly gives all information.

Has anybody seen this before?





Hi, Graeme.  Thanks for the report.  We noticed this just after 1.7 shipped (else we would have fixed it), so you should expect a fix in the next release.  Apologies for the bug.

View solution in original post



I can work around this getting the Disk ID via Get-NaHostVolume and then using that rather than the DrivePath to obtain LUN/volume path via Get-NaHostDisk but thought I'd flag this anyway.

$DriveD = Get-NaHostVolume | where {$_.MountPoints -eq "D:\"}

$Disconnect = Get-NaHostDisk | where {$_.Disk -eq $DrivetoDisconnect.Disk}

Set-NaVol $Disconnect.ControllerVolumeName -Offline



Hi, Graeme.  Thanks for the report.  We noticed this just after 1.7 shipped (else we would have fixed it), so you should expect a fix in the next release.  Apologies for the bug.


Any idea when 1.8 will be released?



As your stock broker will tell you, past performance is not indicative of future results.  However, since its initial release, the Toolkit has been updated approximately quarterly.  1.7 shipped on 1 February 2012.


Thanks - I'll keep an eye out for it!

I found the workaround I posted above didn't always succeed due to this bug. However Get-NaHostDisk will always give you the LUN serial, even if other fields are empty so you can pass this to Get-NaLUN to get the path and work the volume name from that.


Hi Graeme, currently running with Toolkit v3.1.1.181 and seems this still has not been solved. In your case you had Snapdrive disks returned (not complete though) but in my case I had no SD Luns returned at all - eventhough 5 LUNs were created, connected and configured on the Win2008 host.

If I run as follows, I get the non-negative number required message in return.


PS C:\> Get-NaHostDisk -DataOntap

Get-NaHostDisk : Non-negative number required.

Parameter name: byteCount

At line:1 char:15

+ Get-NaHostDisk <<<< -DataOntap

+ CategoryInfo        :NotSpecified:(:)[Get-NaHostDisk}, ArgumentOutOfRangeException

+ FullyQualifiedErrorId : System.ArgumentOutOfRangeException,DataONTAP.PowerShell.SDK.Cmdlets.Windows.GetHostDisk


Goal is to run the NA Powershell reclamation script which does not work for obvious reasons; so I was hoping you have a workaround in the meantime. All feedback appreciated, thanks.



I am running an older version of the toolkit, v2.3 (I must test our scripts and update!) but I noticed some changes with Get-NaHostDisk.

The cmdlet now expects a Disk Index number to be passed to it before the required information is returned.

In our case we have been passing a Drive letter to the Get-NaHostVolume cmdlet to obtain the Disk Index number, then using that with Get-NaHostDisk




thanks for your quick response.

tried to find older toolkit versions, but cannot find any archived versions.

Strange thing is, that SDCLI reports all drives available.

But when I run get-nahostdisk -disk# , the only disk reported is the vmdk disk.

All other snapdrive-created LUN's are returned with the already displayed errors.

I guess that when RDM's are in question, this get-nahostdisk commandlet returns with an error.

Unfortunately I cannot find a location on the netapp site to find help on this Netapp PS Toolkit, except for this community. Do you know by coincedence where I can get help for this PS issue?

best regards



Hi Ben,

I downloaded version 3.1.1 and did some testing. You are correct, Get-NaHostDisk and Get-NcHostDisk does not display information for RDM LUNs. However it does display for VMDKs and Guest OS iSCSI connected LUNs.

I can still run Invoke-NaHostVolumeSpaceReclain on the RDM LUNs though. Hopefully a member of the development team will see this post and can debug the issue.