Microsoft Virtualization Discussions

How to use new-nccluster to create a cluster

AllenChang
1,281 Views

If I have a new environment,

two node,both node are not been setting,

how to use new-nccluster to create a cluster ?

 

I try to use connect-nccontroller to connect the new controller,

but because the admin account not have any password,so it fail

 

so ,how to use the new-nccluster command ?

6 REPLIES 6

Ontapforrum
1,256 Views

There are certain prerequisites. Looks like you will need to setup admin password.

 

Prerequisites as mentioned in the blogpost below:

1) The latest NetApp PowerShell Toolkit (4.3) has been installed
2) Node setup has been run on each node
3) The same admin password has been assigned to each node (security login password)
4) ONTAP 9.1 GA release (but this should work with 8.3 and higher)
5) A cluster base license is required

 

This blog has complete walkthrough (New-NcCluster):
https://netapp.io/2017/03/17/automate-cluster-setup-12-steps-with-ontap-powershell-toolkit-4-1/

 

AllenChang
1,223 Views

Hi Ontapforrum

How to setup the node ?

becasue the cluster setup command will config both the node and cluster,

but I don't find any method to confing the node only
or I need separate config each parameter ? just like node name,node ip,.......?

 

Thanks

AllenChang
1,222 Views

in step 2,I want to config node
so use security login command to config admin password of node
the ip address is get from DHCP
but when I use connect-nccontroller command

Connect-NcController 20.1.1.2 -Credential(Credential)

AllenChang_0-1663140462751.png

it show the error

Connect-NcController : Could not connect to 20.1.1.2 on port 80 for protocol HTTP.

AllenChang_1-1663140503842.png

how to config the node ?

 

 

Ontapforrum
1,219 Views

Bydefault, http (80) is disabled. Try -https instead. If you want try http, then you will need to first enable it.

AllenChang
1,167 Views

I use  -HTTPS to connect,

but it show the other error

Connect-NcController : database cluster_id_rdb is not open

AllenChang_0-1663195386253.png

 

Hi.  Did you ever get past this?  I'm also stuck at: database cluster_id_rdb is not open

Public