Microsoft Virtualization Discussions

NetApp PowerShell Toolkit 4.4 released!

Arpit_Kasliwal

Dear PowerShell community,


We are glad to announce the release of NetApp PowerShell Toolkit version 4.4. This unified release only has enhancements for ONTAP modules and we have kept SANtricity module as same as last release.

 

ONTAP PowerShell Module:
The latest release adds upto 2100 cmdlets and provides maximum API coverage for ONTAP 9.2 and is backward compatible with previous ONTAP releases.

 

Download the PowerShell Toolkit 4.4 from here


Regards,
NetApp PowerShell Toolkit Team

25 REPLIES 25

Re: NetApp PowerShell Toolkit 4.4 released!

shamz
It seems like the internal version number wasn't bumped. I still get 4.2.0.0 from get-natoolkitversion even after a uninstall, reinstall. -S.

Re: NetApp PowerShell Toolkit 4.4 install problem

fvanbavel

Hi,

 

Trying to install PowerShell Toolkit 4.4 on Windows Server 2016 DataCenter and keep getting the following error.

 

"This application requires PowerShell 3.0 or above. Please install the required PowerShell version and then run this installer again."

 

Checked and PowerShell 3.0 is installed on the server

The following is installed

       Windows PowerShell 5.1

       Windows PowerShell 2.0 Engine

       Windows PowerShell ISE

 

Tried holding down Shift and right clicking but do not get the option to run as administrator.

 

 

Re: NetApp PowerShell Toolkit 4.4 released!

UTrentowski

I've Installed the Powershell Toolkit 4.4 on Windows Server 2016 Standard.

Connecting to CDOT SVM's works fine but I get an error when trying to connect to 7-mode filers.

 

PS C:\> connect-nacontroller my7modefiler.domain.local

 

2017-06-08 14:39:46,258 INFO DataONTAP.PowerShell.SDK.ConnectNaController - Cmdlet invocation: connect-nacontroller my7modefiler.domain.local

2017-06-08 14:39:46,259 DEBUG DataONTAP.PowerShell.SDK.ConnectNaController - No credentials provided, consulting cache

2017-06-08 14:39:46,260 DEBUG DataONTAP.PowerShell.SDK.ConnectNaController - Trying RPC

2017-06-08 14:39:46,260 DEBUG NetApp.Ontapi.NaServer - NaServer port changed to 0

2017-06-08 14:39:46,260 DEBUG NetApp.Ontapi.NaServer - NaServer Protocol changed to RPC

2017-06-08 14:39:46,260 DEBUG DataONTAP.PowerShell.SDK.ConnectNaController - Connecting to my7modefiler.domain.local via RPC

2017-06-08 14:39:46,260 DEBUG NetApp.Ontapi.NaServer - <netapp version='1.0' xmlns='http://www.netapp.com/filer/admin'><system-get-ontapi-version /></netapp>

 

connect-nacontroller : Failed to load ntapadmin32 DLL

At line:1 char:1

+ connect-nacontroller my7modefiler.domain.local

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

   + CategoryInfo         : InvalidResult: (DRSSDN31:NaController) [Connect-NaController], Exception

   + FullyQualifiedErrorId : RpcConnectionFailed,DataONTAP.PowerShell.SDK.ConnectNaController

 

2017-06-08 14:39:46,268 DEBUG DataONTAP.PowerShell.SDK.ConnectNaController - Failed to connect to my7modefiler.domain.local

2017-06-08 14:39:46,268 DEBUG DataONTAP.PowerShell.SDK.ConnectNaController - Setting value of global:CurrentNaController

2017-06-08 14:39:46,268 DEBUG DataONTAP.PowerShell.SDK.ConnectNaController - Starting EMS logging

 

 

I already tried and checked a lot of different things:

- Uninstalling and reinstalling the toolkit --> same error

- Uninstall dotNet 4.7, install dotnet 4.5 --> same error (that was the only significant difference I've seen between Windows 10 and Windows Server 2016)

- running powershell in 32bit and 64bit also as Administrator--> same error

- Installed the 4.4 Toolkit on Windows 10 with the same PS Version --> works fine

- Uninstalled the 4.4 Toolkit and installed the oldest Toolkit Version I've found in my archive: 3.2.0.65  --> works fine.

 

PS C:\> connect-nacontroller my7modefiler.domain.local

Name Address Ontapi Version

---- ------- ------ -------

my7modefiler.domain.local 192.168.0.40 1.21 NetApp Release 8.2.4P6 7-Mode: Wed Jan 11 01:07:08 PST 2017

 

 

Any Idea whats wrong the 4.4 and 7-mode on Windows Server 2016?

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Re: NetApp PowerShell Toolkit 4.4 released!

UTrentowski

Version 4.0 (internal version 3.3.0.65) works fine.

Re: NetApp PowerShell Toolkit 4.4 released!

drwoodberry

Any chance to get the toolkit updated to reflect some of the new 9.2 features like encrypted FlexGroup volumes. I see that I cannot use the "-Encrypt" switch when making flexgroup volumes. Will I need to pass the command via InVoke-Ssh in the meantime? I would rather not have to re-write.

Re: NetApp PowerShell Toolkit 4.4 released!

asulliva

Hello @drwoodberry,

 

The API docs (for ZAPI 1.120 / ONTAP 9.2) specifically state that the encrypt option doesn't work with FlexGroup (or Infinite) volumes.

 

 

2017-07-07 12_52_15-Microsoft Edge.png

 

So, the PowerShell toolkit can't support it via cmdlet.  You'll need to use Invoke-NcSsh.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: NetApp PowerShell Toolkit 4.4 released!

drwoodberry

Thanks for the information.

Re: NetApp PowerShell Toolkit 4.4 released!

jet

I have the same issue where i am seeing 4.2 as the loaded version after i have installed the msi for 4.4.  Is this a bug or are we really not loading version 4.4?

 

Along with that i am trying to run invoke-ncssh against a cluster running DOT 9.1P5.  I keep get an error that "An established connection was aborted by the software in your host machine".  I noticed that if i turn off FIPS and re-enable HTTP invoke-ncssh works fine.  Anyone know if there is a way to run invoke-ncssh with FIPS enabled? 

Re: NetApp PowerShell Toolkit 4.4 install problem

BluePenguin

open up a command prompt as admin

 

then run the installer from the command line - ie .\NetApp_PowerShell_Toolkit_4.4.0.msi

 

Should work fine after that

Re: NetApp PowerShell Toolkit 4.4 install problem

shamz

I think you are going to need to read my post a bit more carefully and then edit/remove your post.  This isn't a matter of the installation process, as far as I can see.  The msi package installs fine run as administrator with the standard "double-click".  The version number after installation is incorrect.

 

Now the installer might be so broken that it silently fails, but then it should be fixed. The de-installation could also be so broken that it doesn't remove all of the package, but again, that should be fixed if that's the case.

 

S.

Re: NetApp PowerShell Toolkit 4.4 released!

BluePenguin
Replied to wrong post

Ho hum

Re: NetApp PowerShell Toolkit 4.4 released!

ijustwantthemodule

The link to the download is broken?

 

 

This page isn’t working

mysupport.netapp.com redirected you too many times.

 

ERR_TOO_MANY_REDIRECT

Re: NetApp PowerShell Toolkit 4.4 released!

drwoodberry

So what are the odds we can get the module attritbutes to be updated to reflect the version. For a while now if you get the version of the module it showed with toolkit 4.0 -4.3.

 

ModuleType Version Name ExportedCommands
---------- ------- ---- ----------------
Manifest 4.1.0 dataontap {Add-NaAggr, Add-NaCifsShare, Add-NaCredential, Add-NaFpolicyExtension...}

 

Major Minor Build Revision
----- ----- ----- --------
4 1 0 -1

 

I see in 4.4 the minor version has been incremented to "2". Can the versions shown when you use get-module match the add/remove programs version? I have quite a few scripts that rely on certain versions and I need to validate the version prior to execution. If the module version retrieved by the commandlet matched the add/remove program version, that would be great. 

Re: NetApp PowerShell Toolkit 4.4 released!

asulliva

Remember the PowerShell Toolkit is made up of two separate modules: ONTAP and E-Series.  The toolkit version is increased whenever either of the component modules has a release, even if only one of them was modified, the entire toolkit's version will be increased.

 

Yes, I know this is confusing.  Yes, I know this seems odd.  Yes, I have requested we reevaluate how this is done : )

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: NetApp PowerShell Toolkit 4.4 released!

drwoodberry

No worries, and thanks for the response. 

 

Yes, it is confusing.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public