Microsoft Virtualization Discussions

NetApp PowerShell Toolkit released!


Dear PowerShell community,

We are glad to announce the release of the NetApp® ONTAP® PowerShell Toolkit.


What’s New 

  1. Toolkit introduces REST API functionality for cmdlets to support ONTAP features available through 9.11.1 through both REST and ZAPI.
  2. Toolkit has not made any changes to existing support for ZAPI calls.
  3. PSTK cmdlets use REST API by default from ONTAP 9.10.1 release onwards
  4. Toolkit has not made any changes to existing support for ZAPI calls.
    • To execute cmdlets by using ZAPI calls, use the -ONTAPI parameter like below: 
      1. Connect-NcController ControllerIP
      2. Get-NcVserver -Name vs0 -ONTAPI
    • Set a global connection to execute all cmdlets using ZAPI calls use the -ONTAPI parameter at connection level like below:
      1. Connect-NcController ControllerIP -ONTAPI
      2. Get-NcVserver -Name vs0

PowerShell Toolkit Upgrade and Backward Compatibility

The toolkit name has been changed from DataONTAP to NetApp.ONTAP. To provide backward compatibility i.e. existing scripts compatibility and to allow users to import the module using the previous name, complete the following steps:


PowerShell Gallery

  1. Use cmdlet uninstall-module DataONTAP if an older package is available.
  2. Use cmdlet install-module NetApp.ONTAP to install the ONTAP package.
  3. Execute the following two commands.

Before executing these commands, ensure that “C:\Program Files\WindowsPowerShell\Modules\NetApp.ONTAP” exists. This is the default location where the PowerShell gallery install module resides. If this location has been updated, update the path accordingly.

  1. New-Item -ItemType SymbolicLink -Path ("C:\Program Files\WindowsPowerShell\Modules\DataONTAP") -Target ("C:\Program Files\WindowsPowerShell\Modules\NetApp.ONTAP")
  2. New-Item -ItemType SymbolicLink -Path ("C:\Program Files\WindowsPowerShell\Modules\DataONTAP\\DataONTAP.psd1") -Target ("C:\Program Files\WindowsPowerShell\Modules\DataONTAP\\NetApp.ONTAP.psd1")
  3. Once the commands have completed, import the module using both names “DataONTAP” and “NetApp.ONTAP”.

 NetApp ToolChest

  1. Download the package from the ToolChest.
  2. Extract the package.
  3. Execute Install.ps1 and enter the location where you want to update the existing package or do a fresh installation.
  4. Once the command has completed, import the module using both names “DataONTAP” and “NetApp.ONTAP”.

For more details refer to PowerShell Toolkit Installation Guide 


Toolkit can be downloaded from PowerShell Gallery as well.


NetApp PowerShell Toolkit Team



The NetApp.ONTAP v9.11.1.2208 module is garbage. I don't know how this passed the QA checks.

Jonathan Colón | Blog | Linkedin


Hi all
At least the "New-ncvol -type" and the "New-ncvol -SnapshotReserve" switches don't work. Will these bugs get corrected? 


"Get-NcSnapshot" without any parameters should give you all snapshots on the cluster, as previous versions of the powershell module would, but now you are met with a request to specify a volume. Why? This contradicts the documentation.

If you then specify a volume like *, which is legal, you get 10 snapshots from a single volume. Why?
I'm actually looking for all the snapshots in the cluster and not 10 random.

If I specify a particular volume, then I get a list of 10 snapshots from that volume.
You have broken something that worked really well, don't patronize your users by thinking that you know what they would like to see.

BtW - You can still get all the snapshots from the cluster by using "Get-NcSnapshot -ontapi", but that seems wrong to keep using legacy switches.


can'T use as 7mode Connect-NaController not working well with rpc. cdot we have to include -ZapiCall.
Need to revert this update


Add-NcCifsShare -Name Test -Path /vol_Daten/Daten

Add-NcCifsShare : HomeDirectory parameter specified, which is not supported for ONTAPI call


Perhaps it should work other way? I try all ways but it dont work...


Then I'll answer my own question.
The problem is was Powershell NetApp.Ontap version After downgrade to version creating a CIFS share works without problems.
Should you test software yourself before release? But there are also cooks who do not taste their own food...