Microsoft Virtualization Discussions

NetApp access using connect-nccontroller

Simon_Woodcock
1,113 Views

All,

 

This may be silly question to many, but recently new to the POSH module  for ONTAP, and working with it to extract some data for a customer. However I have a jump host that I have to use, and when I try to connect I'm getting errors such as:

 

 Connect-nccontroller : Could not connect to xx.yy.aa.zz on port 80 for protocol HTTP.

 

I thought this would default to HTTPS, but presuming it can't connect on this port for some reason (which is odd as system manager can) - can anyone shed any light please as quite an urgent issue.

 

Thanks,

 

Simon

2 REPLIES 2

hmoubara
1,070 Views

Hello,

 

The default for POSH is to use https and if failed it will drop to http. if you want to set it to use https or http directly, just use the -http or -https parameter when issuing the Connect-nccontroller.

Ex:

PS >  Connect-Nccontroller -Name cluster1 -http or -https

 

which network IP address are you using to connect via PS (cluster-mgmt lif or node mgmt-lif etc...)? and is it the same IP used to connect to sysmgr.

Also, can you share the output of the connect-nccontroller with -verbose paramter.

 

To get http to work while troubleshooting the reason behind https not working, check wether it is enabled on the cluster level:

 

cluster::> system services web show

External Web Services: true
HTTP Port: 80
HTTPS Port: 443
Protocol Status: online
Per Address Limit: 80
Wait Queue Capacity: 192
HTTP Enabled: false

 

HTTP is disabled by default, you can enable using the command below:

 

cluster::> system services web modify -http-enabled true

 

Hope this answer your question.

 

Thanks 

 

 

 

 

tahmad
857 Views

Hi @Simon_Woodcock 

Were you able to connect successfully, following @hmoubara post?

Public