Microsoft Virtualization Discussions

Powershell Toolkit - Doesn't connect to SVM after moved to new node

ac_ac

Hello, after relocating an SVM to a newly installed node, I can no longer connect to it with the Powershell toolkit. 
Same generic error if I use -https.

 

PS C:\Users\acac> Connect-NcController svm-fileshares.fqdn -Credential $Creds
Connect-NcController : Could not connect to svm-fileshares.its.uow.edu.au on port 80 for protocol HTTP.
At line:1 char:1
+ Connect-NcController svm-fileshares.its.uow.edu.au -Credential $Creds
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidResult: (svm-fileshares.fqdn:NcController) [Connect-NcController], NaConnectionException
+ FullyQualifiedErrorId : HttpConnectionFailed,DataONTAP.C.PowerShell.SDK.ConnectNcController

 

Also currently having issues with snapdrive on exchange not connecting to its SVM after moving the svm to a new node. We moved the svm back to the old node as a work around for this. I have a ticket open for this.

 

Can't move svm-fileshares back to test if it starts working again until a maintenance day.

 

Any ideas?

2 REPLIES 2

Re: Powershell Toolkit - Doesn't connect to SVM after moved to new node

mbeattie

Hi,

 

Have you tried connecting to the cluster via IP Address and using the -Vserver parameter? EG

 

$credentials = Get-Credential -Credential admin
Connect-NcController -Name 192.168.100.2 -HTTPS -Vserver vserver1 -Credential $Credentials
Name                 Address           Vserver              Version
----                 -------           -------              -------
cluster1.testlab.... 192.168.100.2     vserver1             NetApp Release 9.6: Wed Jul 10 10:10:43 UTC 2019

 

What's your case number?

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Powershell Toolkit - Doesn't connect to SVM after moved to new node

ac_ac

Hi Matt,

I just tested connecting with the IP addresses and get the same error.

Case number for this issue, 2008520018, was closed because powershell toolkit is not supported.

Case number for the Exchange Snapdrive issues, 2008521495, currently waiting for autosupport logs to be checked.


I have a feeling the issues are related because they are essentially the same symptoms - move svm to new nodes, then application (Snapdrive or powershell toolkit) doesn't connect with no real error message.

 

Cheers

AC

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public