Microsoft Virtualization Discussions

Highlighted

NetAppDocs breaks with ONTAP 9.1P2 ?

Has anyone else seen this? Toolkit worked fine against ONTAP 8.3.2P5, but breaks now after upgrade to 9.1P2:

 

(cluster name changed for privacy)

 


PS C:\Users\701494>
PS C:\Users\701494> Get-NtapClusterData -name 'clusterxxx' -Credential (Get-Credential admin) -Verbose
VERBOSE: Initializing function: Get-NtapClusterData (NetAppDocs v3.2.0.1759)
VERBOSE: Validating connectivity to system: clusterxxx
VERBOSE: Using supplied credentials
VERBOSE: Trying HTTP/HTTPS
VERBOSE: Connected to clusterxxx using HTTPS
VERBOSE: Skipping EMS logging

 

<clipped the bulk of verbose output>

 

VERBOSE: - Gathering debug information -

VERBOSE: Calling Invoke-NcSystemApi (set -privilege diagnostic -confirmations off; debug vreport show -instance
VERBOSE: - Getting current timestamp -
VERBOSE: - Identifying SystemName -
VERBOSE: - Identifying any errors during processing -
Format-NtapClusterData : Exception calling "Add" with "1" argument(s): "Column 'SwitchSerialNumber' does not allow
nulls."
At line:1 char:87
Get-NtapClusterData -name 'clusterxxx' -Credential (Get-Credential admin) -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (Smiley Happy [Format-NtapClusterData], MethodInvocationException
+ FullyQualifiedErrorId : NoNullAllowedException,Format-NtapClusterData

PS C:\Users\701494>

 

6 REPLIES 6

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Hi David,

 

Is it possible to send me the raw output from this cluster? This isn't necessarily a 9.1P2 issue, other than the possibility of the property name being changed. The real issue is that this condition shouldn't produce a terminating error.  I will send you an email offline to discuss further.

 

Thanks,

 

Jason

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Thanks for your prompt reply Jason! Per our email exchange, the latest pre-release of NetAppDocs you provided corrected the problem! All set!

 

-dave

 

 

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Would you be kind enough to also provide it ?

Is the pre-relase compatible with 9.2 ?

 

Regards,

 

Francisco

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Hi Francisco,

 

I believe we are only a couple weeks away from being able to release the latest version to partners. This latest release is compatible with 9.2.

 

Thanks,

 

Jason

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Any updates or new versions?  I am running version 3.4.0 against a 2 node cluster running 9.3P2.

 

I am getting this error when running the script and then the script terminates:

VERBOSE: Formatting table: DebugVreport
Add-RowToDataTable : Exception calling "Add" with "1" argument(s): "Column 'Object' does not allow nulls."
At C:\Program Files (x86)\NetApp\NetAppDocs PowerShell Module\NetAppDocs\Public\Format-NtapClusterData.ps1:433 char:25
+ Add-RowToDataTable -DataTable ([ref]$dataSet.Tables[$tab ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (Smiley Happy [Add-RowToDataTable], MethodInvocationException
+ FullyQualifiedErrorId : NoNullAllowedException,Add-RowToDataTable

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Hi svanamburgh,

 

We are about ready to release a 3.5.0 version, however this error you are seeing is specific to the system you are pulling from. Would it be possible to get the raw data from the Get-NtapClusterData function for this system for troubleshooting?

 

Thanks,

Jason

Forums