Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Microsoft Virtualization Discussions

Netapp Docs connect error with cDOT

MARC_GALLOWAY

When trying to run NetappDocs against a cDOT array the script returns the below error. I'm able to SSH in via putty.

 

 

PS C:\Users\t15jr5p> Get-NtapClusterData -Name '10.72.66.82' -Credential (Get-Credential) -Verbose | Format-NtapClusterData -Verbose | Out-NtapDocument -WordFile 'c:\temp\nyl_ntapclus_lab01.Docx' -ExcelFile 'C:\temp\nyl_ntapclus_lab01.xlsx' -Verbose

cmdlet Get-Credential at command pipeline position 1
Supply values for the following parameters:
Credential
VERBOSE: Validating connectivity to system: 10.72.66.82
VERBOSE: Using supplied credentials
VERBOSE: Trying HTTP/HTTPS
Get-NtapClusterData : Unable to gather data from system: 10.72.66.82. Reason: Incorrect credentials for 10.72.66.82..
At line:1 char:20
+ Get-NtapClusterData <<<< -Name '10.72.66.82' -Credential (Get-Credential) -Verbose | Format-NtapClusterData -Verbose
| Out-NtapDocument -WordFile 'c:\temp\nyl_ntapclus_lab01.Docx' -ExcelFile 'C:\temp\nyl_ntapclus_lab01.xlsx' -Verbose
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Get-NtapClusterData

WARNING: Empty dataset found so document generation not possible

 

1 ACCEPTED SOLUTION

JGPSHNTAP

For powershell to work in cdot, you need to create a security login access to ontapi.

 

Also, ensure your domain-tunnel is working in 8.3 if you are using domain authentication

View solution in original post

3 REPLIES 3

JGPSHNTAP

For powershell to work in cdot, you need to create a security login access to ontapi.

 

Also, ensure your domain-tunnel is working in 8.3 if you are using domain authentication

View solution in original post

thomasb82

Hi, I'm using version 4.1 with an cDOT 8.3.1 and the cmdlet "Get-NtapClusterData" does not exist.

(Get-NtapClusterData &colon; The term 'Get-NtapClusterData' is not recognized as the name of a cmdlet, function, script file,.....)

 

Is this some kind of addon? Where can I get it?

 

Thanks!

asulliva

Hello!

 

You'll want to start a new topic for new questions in the future...it usually leads to much better visiblity and faster responses.

 

That being said, I beleive that cmdlet is a part of the NetAppDocs package, avaialable from the toolchest here.

 

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public