Community maintenance is complete. Thank you for your patience!

Microsoft Virtualization Discussions

Operation is not supported error

pvbavel

I've just downloaded the Powershell Toolkit 1.7 but I'm unable to import the module, I receive the following:

Import-Module : Kan bestand of (translation:can not load) assembly OntapiPS, Version=1.7.0.112, Culture=neutral, PublicKeyToken=5d4427961a9a0646 o

f een van de afhankelijkheden hiervan niet laden. Minimale machtigingen zijn niet verleend. (Uitzondering van HRESULT:

0x80131417)

At line:1 char:14

+ Import-Module <<<<  dataontap

    + CategoryInfo          : InvalidOperation: (:) [Import-Module], FileLoadException

    + FullyQualifiedErrorId : FormatXmlUpateException,Microsoft.PowerShell.Commands.ImportModuleCommand

I unlocked the dataontap.zip and used the install.ps1 to install the module. The powershell restriction mode is set to unrestricted..., I use it on a 2008 R2 server....

Any ideas to get it working...

Thnx

1 ACCEPTED SOLUTION

pvbavel

I figured it out.... It has to do with folder redirection and running the module from a network share... When importing the module from the local store it works fine...

View solution in original post

1 REPLY 1

pvbavel

I figured it out.... It has to do with folder redirection and running the module from a network share... When importing the module from the local store it works fine...

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public