Microsoft Virtualization Discussions

PSTK Disable the INFO and DEBUG streams

MichaelMcCormick
1,586 Views

Does anyone else have the same issue with the PSTK module loaded from the MS PSGallery where they get screen after screen of Green background text after each command?  Looked into it and it looks like data coming from the Write-Information  and Write-Debug console streams.  I've checked system variables and reloaded the module twice with the same behavior.  It ignores the Preference variables set in the PShost.

1 ACCEPTED SOLUTION

ttran
1,422 Views

Hi MichaelMcCormick,

 

You can see if Debug level is enabled using the following commandlet: Get-NaToolkitConfiguration. What version of the PSTK are you using?

 

 

Regards,

 

Team NetApp

Team NetApp

View solution in original post

3 REPLIES 3

ttran
1,423 Views

Hi MichaelMcCormick,

 

You can see if Debug level is enabled using the following commandlet: Get-NaToolkitConfiguration. What version of the PSTK are you using?

 

 

Regards,

 

Team NetApp

Team NetApp

Francis_Favorini
1,358 Views

What is the default level that is supposed to be set out of the box? Error? It seems to have changed to Debug for version 9.8.0 of the Toolkit. That seems like a mistake.

ttran
1,330 Views

Hi Francis_Favorini,

 

I installed PSTK 9.8 and confirmed the default loglevel is not enabled/off.

 

Here is my reproduction in the lab:

 

PS C:\Users\administrator> import-module dataontap

PS C:\Users\administrator> get-module

ModuleType Version    Name                                ExportedCommands
---------- -------    ----                                ----------------
Manifest   9.8.0      DataONTAP                           {Add-NaAggr, Add-NaCifsShare, Add-NaCredential, Add-NaFpol...

PS C:\Users\administrator> get-natoolkitconfiguration

Log
---
{DataONTAP.PowerShell: OFF, DataONTAP.C.PowerShell: OFF, DataONTAP.HostUtilities: OFF, NetApp.Ontapi: OFF}
Team NetApp
Public