The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to register at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Microsoft Virtualization Discussions

Powershell Module DataONTAP on Windows Server 2016




I've installed the Powershell Toolkit 4.4.0 on a Windows Server 2016 machine with Powershell 5.

After that I've importet the module and tryed to establish a connection:


~> Import-Module DataOntap
~> Connect-NaController myfiler.mydomain
Connect-NaController : Failed to load ntapadmin64 DLL
In Zeile:1 Zeichen:1
+ Connect-NaController myfiler.mydomain
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidResult: (myfiler.mydomain:NaController) [Connect-NaController], Exceptio
+ FullyQualifiedErrorId : RpcConnectionFailed,DataONTAP.PowerShell.SDK.ConnectNaController



It seems that there's a problem with ntapadmin64.dll. In the 32 bit Powershell its the same.


Any suggestions?



I hate to revive a dead thread. But I am currently running into this issue on a Windows Server 2012 R2. Running Dataontap 4.1.0 or 4.4.0 I get this same error.


Connect-NaController : Failed to load ntapadmin64 DLL
At line:1 char:1
+ Connect-NaController XXXXXXXXX
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidResult: (XXXXXXX:NaController) [Connect-NaController], Exception
+ FullyQualifiedErrorId : RpcConnectionFailed,DataONTAP.PowerShell.SDK.ConnectNaController


I've also tried running powershell x86 and x64 and the various powershell versions 3.0-5.0. 


This works fine on Windows 2008R2 and Windows 7 with Dataontap 4.1.0 or 4.4.0.


Any ideas?


I might have a workaround, unless your use-case requires log-in via RPC for some reason. An important point to note is - logging in via RPC is supported only for 7-mode systems. Are you running a 7-mode or Clustered ONTAP?


If you don't need to log-in via RPC, run the command as `Connect-NaController yourController.yourDomain -Credential yourLogInUserName` and enter the password in the credentials dialog box when prompted. That should work without loading the ntapadmin64.dll.


If you're trying to script the commands, and want to avoid being prompted for password, you can run Add-NaCredential beforehand to store the credentials.


Or you can create a credential object in your script as


$secpasswd = ConvertTo-SecureString "PlainTextPassword" -AsPlainText -Force
$mycreds = New-Object System.Management.Automation.PSCredential ("username", $secpasswd)

and then run the command as


Connect-NaController yourController.yourDomain -Credential $mycreds

Hope this helps,




Hello Aparajita,


and thanks a lot. We are running a 7-Mode Metrocluster but using Credentials from a encryptet file is ok.


Connecting to the Controller is now possible and I can do things like Get-NaVol but I have to do some operations on the mounted filer:



I've tryed to run a Mount-NaController. If I'm right it should be possible to do a


cd myfiler


after that but "myfiler" isn't found. It seems that the mountpoint is missing. This makes me courious if its a problem with Server 2016 or with the authentication method change.


It might be a Windows-2016 problem - I remember there were some bugs reported on other cmdlets that perform disk operations (like the VM Conversion cmdlets), but nothing specific on Mount-NaController.


Would it be possible to try it out on an older version of Windows, with the changed authentication mechanism?


Following your last request i found out that our old servers (Server 2012R2) still run with version 4.1.0 of the Powershell Toolkit.  With that I had some troubles using the credential authentication method so I tryed to update these servers to version 4.4.0 and there it was: The same DLL error as on our new 2016 servers.

Since the old servers are still productive I didn't bother to test if the credential authentication method and the mounting command work. I rolled back to version 4.1.0 as fast as possible.


After that I changed the version of the powershell toolkit on our new Windows Server 2016 Machines from 4.4.0 to 4.1.0. After that all of our scripts (using the rpc authentication method) started working again.


So my conclusion is that there are some bugs in verstion 4.4.0 of the toolkit. I can't say if the mounting problem is a new bug or if its related to the authentication method.


Thanks so much for your help!




Thanks for taking the time and analyzing. I'll bring this bug-report to the attention of engineering - hopefully it can be fixed in a future release.





Does this happen if you use an elevated PowerShell session?



If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Yes its the same in elevated mode. And it happens on all Windows Server 2016 machines with this module installed,

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner