Microsoft Virtualization Discussions

Snapmanager for Hyper-V fails because KB not applicable



I'm trying on a fresh and complete Windows-Updated Server 2008 R2 SP1 install Snapmanager for Hyper-V but its

missing the KB2263829. I'm not able to install the Microsoft Hotfix because its not applicable and the Version of the mentioned files

are newer as in the KB Articel. Probleme Snap-Manager for Hyper-V checks hardly of the KB2263829 but its obsolete due some newer/other updates.

How I manage to get Snapmanager installed?

Info: Version of hvax64.exe: 6.1.7601.17939

PS: Also tried quickly with the new 1.2 beta, same issue....






According to my Ticket@Netapp they opened a Bug and trying to Fix the Setup in SMHY 1.2 (not the beta which is available right now).

NetApp confirmed with me yesterday that this is fixed in the final release of SMHV 1.2 (no ETA).  I haven't narrowed down the actual update that caused this yet, but the file version 17939 from these updates has a date stamp of 8/22, so I assume it is a recent patch.  Once I find out which it is I will post.  Thanks!



As a work around, you can force the version of the hvax64.exe and associated files higher than the required version for the SMHV installation by installing this MS hotfix:


The crux of the issue is that the files are ALREADY higher than KB2263829 (file version most recently is 17939, which is several iterations higher than KB2263829 version), and SMHV only checks for the installation of that specific hotfix, and NOT a file version.  So it still may not work, because KB2263829 would still not be installed (KB2586470 would be).

Now the KB you specify is an LDR only hotfix (no GDR, so not sure if that changes anything in some of the logic SMHV is using when it checks for hotfixes), but I don't have a way right now to test to see if installing this after SMHV fails to install helps move the process along.  If you have tried it and it worked (so SMHV initially fails and you can't install 2263829, but then install 2586470 and that allows either 2263829 to install or SMHV to install), that is good to know!



According to the discussions I have seen on this, the SMHV installation does actually check the file version.  However, as you hit upon, with the GDR and LDR versions, there is some confusion when SMHV checks the version.

I have applied this to my testing environment and have confirmed that after installing the 2586470 you are able to directly install SMHV without being prompted about the hotfix.


Thanks for that KB. I've run into the exact same situation and installing KB2586470 resolved it. I can now install SMHV.

Perhaps you guys should pass this along to your help desk people. I called in and explained SMHV was looking for an obsolete hotfix that I couldn't install and was told to go call Microsoft. The rep wouldn't give me a case number so I have no way of following up with him.


Hi, I'm having the same issue with SMHV 1.1 installation to Windows 2008 R2 Core SP1

The Fix is the MS KB above applies to AMD processors which we don't run, so the suggested removal of KB2568088 does not apply.

Is installing KB2586470 really the best solution? I'm not convinced that forcing older file versions will then later be corrected.

I'd prefer to install SMHV 1.2 instead? Is the download available, if so where can I get it?


Thank you for letting us know it worked in your lab.  I will certainly keep this in my back pocket (I have 2 SMHV engagements coming up).

I know SMHV is not ONLY looking at the file version.  If that were the case, anything above 15979 (the build version for the KB2263829) would be okay and SMHV would continue.  But since it was failing this month, the logic is broke at some point in the process.

I will try the LDR hotfix you gave us during my next engagement if they have the same issues with installing SMHV.  Thanks!




Just checked in my notes. I've already have that update installed before installing snap manager (get it from my WSUS). I've need to install 4 other updates but mentioned one was already installed on 2008 R2 SP1.

Did you check download page for update ?

Although that may be an answer, it doesn't fix the issue.  Unfortunately, Microsoft doesn't list any KB that updates these files to the 17939 version (that I could find), which makes me think it is a recent update.  I have a case open with NetApp and will see what direction they can give, because unless someone can determine which update changed the files to the 17939 version it is impossible to move on and install in this scenario.  It is a NetApp issue in how it detects pre-requisites, but hopefully there is another workaround.  I will post as I have more information.  Thanks!

Ok and Hi guys,

I started that threat, in the meantime I had already opened a Case @ Netapp, and they was telling me its a Microsoft issue, since i could not install a hotfix, quite fair...

Meanwhile I did also open a Ticket @ Microsoft about the same issue:

Fact is: Snapmanager checks Hardcoded of a KB-Hotfix Number which is meanwhile obsolete and take over by other hotfixes.

Microsoft could give me some "special unpacked" version of the needed KB-Hotfix to kind of cheat the Snapmanager installation that is the needed KB-Hotfix i manged to run Setup for SMHY.

(Now have wierd problem to get Clusterquorum to get work after this "hack" to get Snapmanager Setup working) - thats why I wont present that Microsoft special hotfix as a Solution, yet.

my Case @ netapp: No. 2003527250

I should get more information tomorrow, keep ya informed.


Well … on Solaris obsolete patch is still present in installed patch database. Even for new releases which integrate all previous patches (analog of slipstream Windows installation) information about applied patches is present. Is there anything similar on Windows?



Thats the point I cannot install the Update mentioned in your link, because its not applicable for my System. It looks like that my System is due another Update already ready, but Snapmanager exactly checks for KB2263829.

I did another installation 1 Year ago and I did not have this problem.

I have exactly the same problem. I cannot install KB2263829, because it is not applicable to my System 2008R2 SP1 standard with Hyper-V.


Do you have Hyper-V role installed?


Yes, Hyper-V Role is installed. Now I have opened Case No. 2003534660.

Mit freundlichem Gruß

i. A. Jobst-Peter Fischer


Computer-Centrum Nord GmbH

Friedhofsallee 124

23554 Lübeck

Postfach: 1848, 23506 Lübeck

Telefon: +49 451 49953-71

Telefax: +49 451 4994758

Mobil: +49 162 2145700



Amtsgericht Lübeck, HRB 790

Geschäftsführer Ulfert Zöllner

Von: aborzenkov

Gesendet: Donnerstag, 20. September 2012 15:04

An: Fischer, Jobst-Peter

Betreff: - Re: Snapmanager for Hyper-V fails because KB not applicable


Re: Snapmanager for Hyper-V fails because KB not applicable

created by aborzenkov<> in Products & Solutions - View the full discussion<>

Do you have Hyper-V role installed?

Reply to this message by replying to this email -or- go to the message on NetApp Community<>

Start a new discussion in Products & Solutions by email<> or at NetApp Community<>


"to my System 2008R2 SP1 standard with Hyper-V"

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.