Microsoft Virtualization Discussions

Toolkit not running after upgrade to 9.7 - any assistance

netapp711
3,237 Views

I used to run this command line to output my NetApp info on NetApp 9.3, I recently upgraded to 9.7 version and now this does not work.

 

I was given this by a support person years ago, not sure how I can get this information again. Any help would be appreciated. 

 

I would run this import first:

Import-Module 'C:\Program Files (x86)\NetApp\NetAppDocs PowerShell Module\NetAppDocs\NetAppDocs.psd1'

 

Get-NtapClusterData -Name 'x.x.x.x' -Credential admin| Format-NtapClusterData | Out-NtapDocument -WordFile 'C:\Output\ABC_ECF.Docx' -ExcelFile 'C:\Output\ABC_ECF.xlsx'PS

 

Looking to see if there is a update to this that I could download.

Thanks

1 ACCEPTED SOLUTION

parisi
3,155 Views

I don't think there's a newer file.

 

The error suggests there's something wrong with the module itself as opposed to being related to the ONTAP upgrade.

 

Maybe try to uninstall/reinstall the module?

 

https://docs.microsoft.com/en-us/powershell/module/powershellget/uninstall-module?view=powershell-7.1

View solution in original post

5 REPLIES 5

parisi
3,169 Views

This is the latest NetAppDocs:

 

https://mysupport.netapp.com/site/tools/tool-eula/netappdocs/download

 

That exact command worked for me on my ONTAP 9.8 system:

 

PS C:\Users\Administrator> Get-NtapClusterData -Name x.x.x.x -Credential admin| Format-NtapClusterData | Out-NtapDocument -WordFile 'C:\ABC_ECF.Docx' -ExcelFile 'C:\ABC_ECF.xlsx'
WARNING: The following document parameters were not specified: CustomerName, CustomerLocation, ProjectName, AuthorName. See the relevant FAQ entry in the help pages for more information on how to manually update the cover pages of the output document(s).

 

parisi_0-1615302137232.png

 

parisi_1-1615302268969.png

 

 

netapp711
3,157 Views

netapp711_0-1615318948244.png

I get this error, not sure what I am doing wrong. I will check out the documentation and see what I am missing.

 

This command worked prior to my upgrade. 

 

I ran this Import prior to running :

 

Import-Module 'C:\Program Files (x86)\NetApp\NetAppDocs PowerShell Module\NetAppDocs\NetAppDocs.psd1'

Is this import correct? or is there a newer file to import?

parisi
3,156 Views

I don't think there's a newer file.

 

The error suggests there's something wrong with the module itself as opposed to being related to the ONTAP upgrade.

 

Maybe try to uninstall/reinstall the module?

 

https://docs.microsoft.com/en-us/powershell/module/powershellget/uninstall-module?view=powershell-7.1

netapp711
3,038 Views

Can you tell me what version of the Toolkit you are using? 

 

still not having any luck running. thanks

parisi
3,031 Views

NetApp Docs version 3.7.0

 

PowerShell toolkit 9.8.0

 

PS C:\Users\Administrator> Get-NtapDocsVersion
_ __ __ ___ ____
/ | / /__ / /_/ | ____ ____ / __ \____ __________
/ |/ / _ \/ __/ /| | / __ \/ __ \/ / / / __ \/ ___/ ___/
/ /| / __/ /_/ ___ |/ /_/ / /_/ / /_/ / /_/ / /__(__ )
/_/ |_/\___/\__/_/ |_/ .___/ .___/_____/\____/\___/____/
/_/ /_/
NetAppDocs v3.7.0

PS C:\Users\Administrator> get-natoolkitversion

Major Minor Build Revision
----- ----- ----- --------
9 8 0 0

Public