Microsoft Virtualization Discussions

Unable to use Add-NaLicense for Disk Sanitizer License

ADMINSTEWARJ

Hoping someone has come across this issue before.

Trying to automate the deployment of a NetApp Filer using powershell, and utilise Add-NaLicense. It works well until trying to add the Disk Sanitizer license where the script hangs. Looking at the console I can see the NetApp is waiting for a prompt:

Filer> You will not be able to remove this license, are you sure you

wish to continue? [no]

I tried the following with the same result.

Add-NaLicense xxxxxx -Confirm:$false

2 REPLIES 2

cknight

This is a Data ONTAP API bug, not something we can address in the Toolkit.  Merely calling the API remotely to add this license causes ONTAP to prompt for confirmation on the controller console.  So while this is inconvenient, the sticky nature of this license means it only has to be applied once.  Sorry for the trouble.

vinith

Hi Stewarj thanks for bringing this to our attention.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public