Microsoft Virtualization Discussions

What is proper syntax for PowerShell toolkit cmdlet "Set-NcSecurityConfig"?

Girton

What is proper syntax for PowerShell toolkit cmdlet "Set-NcSecurityConfig" for the "SupportedProtocols" parameter for use with ONTAP 9.3?  No matter what I try, I keep getting the following error:

    Set-NcSecurityConfig : Unexpected array element: security-supported-protocols

 

I am using PoweShell Toolkit 4.3.0.0.

 

I've looked at the help for this parameter  for this cmdlet:
    -SupportedProtocols <String[]>
        Data ONTAP Supported Protocols.
        Possible values: "tlsv1_2", "tlsv1_1", "tlsv1" ,"sslv3"

        Required?                    false
        Position?                    named
        Default value                
        Accept pipeline input?       true (ByPropertyName)
        Accept wildcard characters?  false

 

I've tried the following and received the same error:

  • Set-NcSecurityConfig -Interface ssl -SupportedProtocols TLSv1.1
  • Set-NcSecurityConfig -Interface ssl -SupportedProtocols "TLSv1.1"
  • Set-NcSecurityConfig -Interface ssl -SupportedProtocols {TLSv1.1}
  • Set-NcSecurityConfig -Interface ssl -SupportedProtocols tlsv1_1
  • Set-NcSecurityConfig -Interface ssl -SupportedProtocols ('tlsv1_1')

 

I've even used the "Get-NcSecurityConfig -Interface ssl" cmdlet, and used the "SupportedProtocols" protocols in the format it returns for the "Set-NcSecurityConfig" command:

{TLSv1.2, TLSv1.1, TLSv1}.

 

I've look for known bugs, existing support cases, Community posts, and haven't found anything  that would help.

 

I'd appreciate any help that could be provided.

0 REPLIES 0
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public