Network and Storage Protocols

Altavault slow SMB performance


We recently introduced a Altavault appliance into our environment and I am seeing some super weird SMB behavior that also has tech support scratching their heads.


The altavault is currently wired to the network with just one 10GB connection to narrow down teaming issues etc.


On any of my Micorsoft 2012 and 2012 R2 servers copying a file to the SMB/CIFS shares will start out blazing fast at ~ 500MB/s but then drop to ~5MB/s after about half of a 5GB file. If I stop that file transfer and then kick off another copy it usualy starts at 5MB/s and just hangs at that speed. Every 10-12 tries it will copy at full speed for the whole file.


If I do the same copy from one of my 2008 R2 VM's the whole copy runs at ~ 120MB/s no matter how many times I do the copy.


I have tried different 10GB ports on the Altavault as well as switch just to rule out a hardware issue.


I have also tried pretty much any Google article I can find such as changing all the TCP offload settings on the VMNIC, disabling SMB signing etc. Nothing has helped.


Has anyone seen anything like this? This is driving me insaine, brand new gear we can't get to work with server 2012/2012R2.  



By chance are you using the "Primary" interface as well? I've seen an issue where when you temporarily shut down the Primary interface from the switch, the transfer stops due to an incorrect route configurations. Meaning you might be routing out the incorrect interface depending on your direction. 


However, I had a very similar issue and was able to get a stable speed of 400MB/s checking the following. I should note that I still feel like there's still a bit of room for improvement.


I'd also check:

- MTU sizes for the entire path (Hosts, Switches, AltaVault, Etc)

- Jumbo frames for the Windows host if you are using 9000

- Network interfaces for the entire path (Hosts, Switches, AltaVault, Etc.)

- That SMB signing is not set for the Windows hosts  which it sounds like you've already checked

- Check any group policy that might have an affect. 

- Turn of anything that might proxy the traffice to verify the speed. I.E. (McAfee DLP, etc)


I'd also consider a slightly larger file to transfer do to the burst. 



I'd also check this article



I'm not sure if this will help but I hope it does.