Network and Storage Protocols



Hi all,

Ok...I have to be brain dead as this is not working as per Instructions...please advise.

Trying to get the NEW on the FAS2020, following the Netapp BIOS/BMC Diagnostics Download and Instructions manual.

I downloaded the zip file to my PC (WinXP)

As per Instructions...Loged onto filer:

testfiler>sotware install http://mypc/sharename/zip file

Fails..unable to open connection to mypc

Also tried using the following from another document I found:: Data-Ontap Commands

testfiler> software install http://username:password@mypcname:80/path/

Another instance references yet another command syntax: EG http://[username:password@]host:port/path

Notice the brackets around username and the @ symbol?? WinXP IS NOT a WEBSERVER...I downloaded Mongoose (xp webserver) and this still does not work.

Uploaded the same file to a WEBSERVER......changed the paramiters...STILL NOT WORKING.

There has got to be an esier way of doing this??

Anyone care to elaborate??


Brain dead today



Why not copy the zip files to the /etc/software directory of the root volume using cifs or nfs? Then you can use the software install command without an url.


Hi Pascal,

Thanks, seems that would be the easiest way, so have gone ahead and done just that. Will run the update later tonight.

I do have one other question if I may, as I am Upgrading my FAS2020 from 7.3.5>7.3.6 along with BMC and Disk FW updates.

As documentation has mentioned, I wanted to update all firmware before doiing the Ontap 7.3.6 update.

With regards to disk_fw update, it mentions that in Ontap 7.3.5 (currently installed and running) it can auto update nehind the scenes.

So I downloaded/extracted and copied the disk_fw file into the etc/dosk_fw folder.

That was 24 hours ago.....and the disks and Autosupport still show NA01...NOT NA02....any reason why it is not updating automatically?? Do I need to initiate it with the update command?

Tks in advance



Do you have the option raid.background_disk_fw_update.enable set to ON? Can you verify that the LOD file for that specific disk is present in the /etc/disk_fw directory?

Also background disk fw updates only works for raid_dp nd raid4 + syncmirror raidgroups. Do not execute the disk_fw_update command as this will be disruptive!

Background fw documention: for


Hi Pascal;

Update for you, and anyone who drops in.

I would have to say that the documentation leaves out one important fact. As I did download the "ALL.ZIP" file, extracted it, and copied it into the etc/disk_fw mentioned above.

Once that is done, as per documentation, the system will see the new file and therefore do the update. This is WRONG, as I just managed to prove that.

Although the new file is indeed there, the system will still see the OLD file as well, and hence WILL NOT do the update.

I finally figured this out when I looked into the logs and saw the following:

dfu.fwDownloadFailedMultFiles                          Download failed due to multiple firmware files found for Disk type.

So, a couple of things.

1) first delete everything in the disk_fw folder, then paste in the new files from the


2) once the new files are copied into the folder, make sure to either rename, or remove the older versions.

In my case, there were two files



I deleted both, and the update started imediatley after.

Not sure what the FVF files is?? Hope its nothing critical??