Network and Storage Protocols

Get the proper Group & Owner from Netapp (using autofs, sssd)



I have a NAS (netapp). with a windows file server that has samba shares connect to AD.

I would like to mount some shares from the NAS onto my ubuntu 16.04 server. When I mount them, I get the group and owner listed as root. I would like to get the proper group and usernames that are listed on the NAS. I will have 20+ users connecting to the server to access the NAS, so i don't want to mount as a specific user, I just want the already established groups and owners to list when a user looks at the directory.  I have also tried using NFS to mount the shares, but instead of the root for group and user, and I get some arbritary number i.e.  4294967294
Here are my autofs config files


/NAS /etc/auto.cifs-shares  --ghost

home -fstype=cifs,rw,sec=krb5 ://my-nas/home\$

sssd and kerberos are configured so I am able to login to the unbuntu server with my AD credentials and mount via autofs.

Thanks a lot for you help!



I meant to say that I have also tried using NFS, but it still doesn't work.    Also, if I specify a uid and gid, I get the arbritray number (however, I don't want to have to do this since there will be many users connected to the NAS, as mentioned above).


Thanks so much!