Network and Storage Protocols

vfiler root password not being accepted by powershell connect-nacontroller - how can I validate?


So I've been having trouble connecting to one particular vfiler as the root credential in the Powershell toolkit. We use the same password on all the other ones I connected to, I was attempting to use saved na-credentials (in my profile, non-system scope) but tried explicitly connecting w/ credentials too.  I went in via SSH to the controller, and then switched to the vfiler context and ran "passwd" on root and changed it to the same password I already thought it was, retried, no dice.  I then added a new user "admin2" --attempting to add it with the same password--but it says the password is invalid because it requires a number.  Our standard admin password is a lot of characters and a mix of cases, but no numbers.  So I used another password, it took it... and now when I connect via powershell direct to the vfiler, it works when I use that credential.  Both users are in the local administrators group on the filer itself.

Anyone have any idea what could be going on?

BTW the error when using Connect-NaController laxsal1-credential root was:

(I typically do just connect-nacontroller laxsal1 and it should use the saved credential, which I added/removed several times; same error either way).

Connect-NaController : Incorrect credentials for laxsal1.

At line:1 char:21

+ Connect-NaController <<<<  laxsal1 -credential root

    + CategoryInfo          : InvalidResult: (laxsalflr01:NaController) [Connect-NaController], NaAuthException

    + FullyQualifiedErrorId : HttpConnectionFailed,DataONTAP.PowerShell.SDK.ConnectNaController

Connect-NaController laxsalflr01 -credential admin2

(admin2 being the new) works fine.

Since I can't ssh to the vfiler itself, how can I validate on the vfiler somewhere else that the root password is accepted as we have it set?  Is there something equivalent to a sudo command that would force it to prompt me and validate root? 



also, likely completely unrelated but maybe some guru knows... or maybe there's some odd corruption item that could relate, who knows.  Now that I got in as admin2 I'm a bit more confused than when I started.

This particular filer should be configured as though it's using NT homedir matching... but both "cifs homedir" in CLI under vfiler context, and the get-nacifshomedir commands return that it is not.  Yet there aren't explicit shares configured for each ID, and it's working with the NT style matching... "No CIFS home directory paths." ... I can load the volume via the share for where the home dirs are and see there are 93 directories there w/ NT names and the clients map as \\laxsal1\uid ...  can I be missing something?