ONTAP Discussions

9.4 Cluster LIF rename

mpaniwozik
8,835 Views

I'm attempting to rename a cluster LIF on an AFF A-300 running 9.4p1. When doing the rename, it just adds what I specify as the new name to the end of the existing name rather than replacing the entire name. Are cluster LIFs re-nameable or is there another way to go about doing it? I've tried from both admin and advanced mode on the local node but no luck. See below for an example of what i'm seeing.

 

Existing LIF name: cluster1-01_clus1 

I'd like to change to cluster1-02_clus1

When trying to change it, my name comes out as cluster1-01_cluster1-02_clus1

My command to make the name change is: net int rename -v Cluster -lif cluster1-01_clus1 -newname cluster1-02_clus1

I just adds the new name to the end of the existing.

1 ACCEPTED SOLUTION

AlexDawson
7,298 Views

Hi there!

 

This is by design and has been since 8.3, and is also present in 9.6.

 

Cluster LIFs only must contain the cluster name. If they do not contain the cluster name, it is prepended to the LIF name.

 

Thanks!

View solution in original post

13 REPLIES 13

SpindleNinja
8,738 Views

Are you able to rename non-Cluster LIFs ok?   

 

 

christsai
8,716 Views

Check all LIFs name, I think you already have the LIF named "cluster1-02_clus1", the LIF name can't be duplicate

mpaniwozik
8,631 Views

I am able to completely re-name non Cluster LIFs. I also tired renaming one of the cluster LIFs to just TEST and all it did, was add TEST to the end of the current name after the underscore, making it cluster1-02_TEST.

robverhoeven
8,485 Views
Hi all, I have exactly the same issue! Somebody found out what is wrong...Is this a bug? FAS2750 switchless cluster ONTAP 9.4P4 Thanks, Rob

christsai
8,469 Views

I have test on simulator, I think it's LIFs name duplicate issue.

 

If you are already have LIF named cluster1-01_clus1 and cluster1-02_clus1, when you want rename cluster1-01_clus1 to cluster1-02_clus1, the system will not let you rename to cluster1-02_clus1, because the cluster1-02_clus1 is already exists, so the LIF name will auto change to cluster1-01_cluster1-02_clus1.

robverhoeven
8,454 Views
Not the case for me....all LIF's have unique names. Thanks, Rob

SpindleNinja
8,430 Views

it does sound goofy.  I'd open a case and see what support says.  

 

iehrenwaldHBG
8,251 Views

Did you ever find a solution or explanation for this?

scottharney
8,173 Views

I've observed the same behavior in 9.4P3. renaming cluster role LIFS appends clusX to whatever name you assign automatically.   For example if I rename a cluster lif named clusternameX_clus1 to myspecialinternalname_lif1_e0A , it get's renamed to myspecialinternalname_lif1_e0A_clus1 even though I didn't put the "_clus1" as part of the -newname value.  Not sure if this is a bug or intended feature.  That said I don't generally rename cluster lifs or worry about their naming and generally advice my customers to leave these alone. They're pretty obvious in both system manager and netw int sho,

RainerTrettl
7,351 Views

Is that already fixed? I have the same behavior with 9.5P1. 

Thx!


@mpaniwozik wrote:

I'm attempting to rename a cluster LIF on an AFF A-300 running 9.4p1. When doing the rename, it just adds what I specify as the new name to the end of the existing name rather than replacing the entire name. Are cluster LIFs re-nameable or is there another way to go about doing it? I've tried from both admin and advanced mode on the local node but no luck. See below for an example of what i'm seeing.

 

Existing LIF name: cluster1-01_clus1 

I'd like to change to cluster1-02_clus1

When trying to change it, my name comes out as cluster1-01_cluster1-02_clus1

My command to make the name change is: net int rename -v Cluster -lif cluster1-01_clus1 -newname cluster1-02_clus1

I just adds the new name to the end of the existing.


 

LSOTECHUSER
7,259 Views

I have exeperienced the same behavior. I am setting up a new FAS2750 and have tried to rename the cluster LIFs to be consistent with our other LIF naming and the host name is appended.  We are running 9.5p7

 

Is there a work around for this behavior?

AlexDawson
7,299 Views

Hi there!

 

This is by design and has been since 8.3, and is also present in 9.6.

 

Cluster LIFs only must contain the cluster name. If they do not contain the cluster name, it is prepended to the LIF name.

 

Thanks!

simpsonjh
7,177 Views

We had this problem as well due to the setup going a bit screwy. It ended up naming the Lifs with 4 and 5 instead of 3 and 4. So I reanmed the managment adapters and that took though like others here I now have naclu01_03_naclu-03_clus1. I now cant make any name changes to this interface. Is that also to be expected? 

Public