ONTAP Discussions

Assigning Disks in a Cluster


Hi, Im new to NetApp and am using the Simulator to help my development.


I setup a 7mode simulator with no issues. 


I have now setup a DataOnTap 8.1.0, two node cluster.  It has 2 shelves disk ID's are v4.xx and v5.xxx.


The v5.xxx disks are assigned to either aggregate or spare.


The v4.xxx disks are currently present but unassigned.  Under the 7mode simulator I can assign these disks with the "disk assign all" command.


This command dosent seem to work in the cluster mode. 


rug-filer-clt::> disk assign all


Error: "assign" is not a recognized command




How do I assign these unassigned disks to the cluster and how do I switch autoassign on ?


Any guidance would be much appreciated.


Re: Assigning Disks in a Cluster



Can you try this

clus-bull-catfish::storage> disk assign -all true -node <specify the node name>

    bull    catfish

This should work.



View solution in original post

Re: Assigning Disks in a Cluster


Even for auto assign, node wise you can make it on or off:

clus-bull-catfish::storage> disk option modify -node bull -bkg-firmware-update on -autocopy on -autoassign on

clus-bull-catfish::storage> disk option show -node bull

                      Node: bull

Background Firmware Update: on

                 Auto Copy: on

               Auto Assign: on

Re: Assigning Disks in a Cluster


Hi I wants to assign my all spare disks to cluster but I am unable to do it

can you help me out?

Re: Assigning Disks in a Cluster


Hi, I too facing the above issue and yet to assign storage space disks. Therefore i used command

storage disk assign –all true –node lambic-02 but it gets aborted

lambic::> cluster show

Node                  Health  Eligibility

--------------------- ------- ------------

lambic-01             true    true

lambic-02             true    true

2 entries were displayed.

lambic::> storage disk assign

Error: "assign" is not a recognized command

can someone suggest me what needs to be checked and how do i fix it.

kind regards, rakesh

Re: Assigning Disks in a Cluster


Sorry for opening up such an old post but as it was along the same lines, I thought I might as well.


So I have installed a 2 node cluster and am following some course material about setting up aggregates in a clustered environment. In setting up my cluster, I assigned all disks to one node (when I tried to assign a set number to 1 node, I just got an error saying I could not specify a node name and had to use the auto assign command). This means that when I follow the course material and set up a new aggregate, I can only ever create an aggregate from my second node. However, in the picture from the course material, it shows both cluster nodes with disks available. Is this correct or should it be that only 1 node owns the disks? Or should I be able to split the disk assignment and add some to node 1 and some to node 2?




Re: Assigning Disks in a Cluster


Ok so this was obviously a config issue. I was using 8.3 clustered mode so thought I would revert back to 8.2, set up the first node, assign all disks, then create second node, join it to the cluster and then use the assign disks to that node. Weather I missed a step off in 8.3 or its set up differently or theres a bug, for whatever the reason, it worked with 8.2 sim but not 8.3 sim. So when I create an aggregate, I can now see both nodes and their disks.

Re: Assigning Disks in a Cluster


i am also facing the same problem as  Error: "assign" is not a recognized command


hadoop::> rows

hadoop::> cluster show
Node Health Eligibility
--------------------- ------- ------------
hadoop-01 true true



hadoop::> hadoop::>

Error: "hadoop::>" is not a recognized command

hadoop::> storage disk assign –all true –node hadoop-01

Error: "assign" is not a recognized command



hadoop::> version
NetApp Release 8.1X45 Cluster-Mode: Sat Sep 10 02:25:01 PDT 2011

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums