ONTAP Discussions

DataOntap 8.2P3 7-Mode - ASUP - RFC not RFC 2822 compliant

After upgrade my Storages (FAS 6080) to the version 8.2P3 7-Mode, the ASUP are still send to NetApp and internally but no to the the partner´s email.


The partner (who I work) uses GMAIL servers to receive the emails. The customer SMTP server is receiving this errors messages to send the ASUP to GMAIL:

20131119:12:47:13|2104295|9481|Processing Domain -|xxx.com|

20131119:12:47:13|2104295|9515|DNS Lookup Returned -|[(1, 'aspmx.l.google.com', ('',)), (5, 'alt1.aspmx.l.google.com', ('',)), (5, 'alt2.aspmx.l.google.com', ('',)), (10, 'aspmx3.googlemail.com', ('',)), (10, 'aspmx2.googlemail.com', ('',))] fromCache=False|

20131119:12:47:13|2104295|9516|Connecting to Domain -|xxx.com|

20131119:12:47:13|2104295|9487|Block timeout in seconds -|180|

20131119:12:47:13|2104295|9488|Connecting to MX -|aspmx.l.google.com|

20131119:12:47:13|2104295|9489|Connecting to A -||

20131119:12:47:13|2104295|9491|Channels Vip vipid:bindhost -|

20131119:12:47:13|2104295|4099|Connecting to <BindHost:ConnectHost:ConnectPort> -|

20131119:12:47:14|2104295|4139|-|Reply: '220 mx.google.com ESMTP 8si1948307yhq.182 - gsmtp'|

20131119:12:47:14|2104295|9492|Connection Status <status> -|1|

20131119:12:47:14|2104295|4139|-|Sending: EHLO mx2.client.jus.br|

20131119:12:47:14|2104295|4139|-|Reply: '250-mx.google.com at your service,

20131119:12:47:14|2104295|9523|Starting SendSmtpMsg in domain -|xxx.com|

20131119:12:47:14|2104295|9570|BATV values are DSN_BVP_enable: <IsEnabled> mail_from: <Mail From> mdoutbound <IsOutbound> selfdeliveryMode <Delivery Mode> -|1:prvs=1028916b52=netapp@tjrj.jus.br:1:0|

20131119:12:47:14|2104295|4139|-|Sending: MAIL FROM:<netapp@client.jus.br> size=675966|

20131119:12:47:15|2104295|4139|-|Reply: '250 2.1.0 OK 8si1948307yhq.182 - gsmtp'|

20131119:12:47:15|2104295|4139|-|Sending: RCPT TO:<support.netapp@xxx.com>|

20131119:12:47:15|2104295|4139|-|Reply: '250 2.1.5 OK 8si1948307yhq.182 - gsmtp'|

20131119:12:47:15|2104295|4139|-|Sending: DATA |

20131119:12:47:15|2104295|4139|-|Reply: '354  Go ahead 8si1948307yhq.182 - gsmtp'|

20131119:12:47:20|2104295|4139|-|Reply: '550-5.7.1 [xxx.xxx.xxx.xxx     11] Our system has detected that this message is

550-5.7.1 not RFC 2822 compliant. To reduce the amount of spam sent to Gmail,

550-5.7.1 this message has been blocked. Please review

550 5.7.1 RFC 2822 specifications for more information. 8si1948307yhq.182 - gsmtp'|

20131119:12:47:20|2104295|4139|-|Sending: RSET |

20131119:12:47:20|2104295|9563|Exception occurred: Type=<error type> Exception=<exp>  -|<class 'ct_smtplib.SMTPServerDisconnected'>:(-1, 'Unexpected EOF')|

20131119:12:47:20|2104295|9525|Generating DSN||

20131119:12:47:20|2104295|9526|No DSN to be generated for this message.||

20131119:12:47:20|2104295|9561|Delivery failure. <Notification message id> : <Retry Count> -|1|

20131119:12:47:20|2104295|9506|Closing SMTP Connection||

20131119:12:47:20|2104295|9480|Finished processing msgid -|2104295|


Re: DataOntap 8.2P3 7-Mode - ASUP - RFC not RFC 2822 compliant

Hello Fabio,

Did you manage to fix this issue? Getting the same on a FAS3170 with 7-mode DOT 8.2.

Kind regards,

Pedro Rocha.

Kind Regards,
Pedro Rocha

Re: DataOntap 8.2P3 7-Mode - ASUP - RFC not RFC 2822 compliant

Hi Pedro,

In my case, the customer has a Microsoft Exchange as a Mail Server and a Mcafee as a Relay Server after the MS Exchange. My Storages had the mailserver option pointed to Mcafee and always worked fine. After the update, we try to change the mailserver option to MS Exchange and began to work fine. So, the problem did not solved but the workaround solved it.


Cloud Volumes ONTAP
Review Banner
All Community Forums