ONTAP Discussions

Deleting stale cluster peers, ONTAP 9.1 & 9.3


Hello, friends. I have two clusters who once had SnapMirror relationships, but we're breaking up the band. I deleted the SnapMirror relationships, vserver peers, and cluster peers on the destination side but failed to do anything like that on the source side. Now there's cluster peer relationship and several stale SnapMirror relationships visible on the source side that I can't delete.


  • Attempting to delete the cluster peer results in "Nope: A Snapmirror destination exists in this cluster." 
  • "snapmirror list-destinations" on the source cluster results in no entries
  • "snapmirror show" on the source cluster shows a few stale entries where the destination path is on the old destination cluster in paths that no longer exist on the destination cluster.
  • No snapmirror commands on the source cluster work when trying to affect the stale destination paths on the destination cluster

Thankfully some network connectivity still exists, because I was able to recreate the cluster peer relationship. The destination vserver on the destination cluster has since been deleted, however, so further commands to "snapmirror release" on the source cluster still fail because it can't find the destination vserver. 


Anyway, that's all quite a lot. Really the goal here is to delete (forcibly, if necessary) the cluster peer relationship. Any ideas to get rid of these stale dependencies?





Have you tried the "snapmirror release -destination-path <path> -force true" command from the source cluster? Should forcibly remove the relationship. 


I have, yeah. Any "snapmirror release" command from the source cluster (at any permission level, admin/advanced/diag) results in 

Error: command failed: Failed to get information for Vserver [deleted destination vserver]. (entry doesn't exist)




::>* vserver peer delet -vserver abc -peer-vserver xyz -force 


Hmm, in that case you may need to temporarily rebuild the destination SVM/DP vol, re-initialize the relationship, and then perform the snapmirror release to get everything to clean up properly.


That's what I would try, someone else might chime in with a better idea though. 🙂  




Darn the luck, it didn't work. I was able to recreate the SVM peer relationship, recreate DP volumes, re-establish and initialize the relationship, and then delete-and-release properly, but there's still an artifact of that relationship on the source cluster. I might have to reach out to support after all.


Please try 

::>* vserver peer delet -vserver abc -peer-vserver xyz -force

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner