ONTAP Discussions

Disable local protection for Application

DavidFartouk

Hi, 

We have two applications configured on ontap 9.4 and we would like to disable the automatic snapshots:

application show-detail :

 

=============================================================================
Vserver: ISCSI-NFS-DR
Application: driscsids02
Application Template: VSIOnSAN
=============================================================================

Application Protection Information
----------------------------------
Is Supported: true
Is Protected: true
Local RPO: hourly
Local RPO Description: 24 hourly, 7 daily, 2 weekly snapshots
Remote RPO: none
Remote RPO Description: none

SAN Storage Element
-------------------
Component: vsidata_ds
Storage Service: value
Element: driscsids02_lun
Path: /vol/driscsids02_sata/driscsids02_lun
Serial Number: 816Zq]NrSkuX
Size: 5TB
Igroups: DR-ESXI-HOSTS
LUN IDs: 1

 

1 ACCEPTED SOLUTION

Ontapforrum

Don't know if  your question is that simple or there is more to it.

 

Ok, anyway this is what you can do to disable the automatic snapshots: 

 

1) Go to SVM : ISCSI-NFS-DR
2) Go to this volume : driscsids02_sata
3) There should be menu items on the top (Not sure, how GUI looks in 9.4, take a look in ONTAP Docs), look for 'snapshot copies' and click Configure, there should be 'Enable schedule snapshots', basically here you can 'disable' automatic or storage side snapshoting. This is a storage side snapshot (Basically crash-consistent), if it's an application then there will some sort of 'snapshots' triggered via backup-host (snapcenter or any 3rd Party software).

 

Looking at the Volume PATH:
Path: /vol/driscsids02_sata/driscsids02_lun

 

In cDOT, we don't use /vol/, it's just root '/'. So, that volume must have been migrated from 7-mode filer ?

 

In any case, you should be able to disable 'automatic' snapshots using the steps mentioned above.

View solution in original post

5 REPLIES 5

Ontapforrum

Don't know if  your question is that simple or there is more to it.

 

Ok, anyway this is what you can do to disable the automatic snapshots: 

 

1) Go to SVM : ISCSI-NFS-DR
2) Go to this volume : driscsids02_sata
3) There should be menu items on the top (Not sure, how GUI looks in 9.4, take a look in ONTAP Docs), look for 'snapshot copies' and click Configure, there should be 'Enable schedule snapshots', basically here you can 'disable' automatic or storage side snapshoting. This is a storage side snapshot (Basically crash-consistent), if it's an application then there will some sort of 'snapshots' triggered via backup-host (snapcenter or any 3rd Party software).

 

Looking at the Volume PATH:
Path: /vol/driscsids02_sata/driscsids02_lun

 

In cDOT, we don't use /vol/, it's just root '/'. So, that volume must have been migrated from 7-mode filer ?

 

In any case, you should be able to disable 'automatic' snapshots using the steps mentioned above.

DavidFartouk

Hi, 

Thanks for the reply. 

the snapshot configuration is not present on the volumes/luns  we can only see it as part of the application 

 

Ontapforrum

Ok, just give me the screenshot of snapshots for that volume, either via GUI or use following CLI:
::> snapshot show -vserver ISCSI-NFS-DR -volume driscsids02_sata

 

This will easily tell us 'what type of snapshots are configured' .

DavidFartouk

Hi, 

Due to the capacity issues that the snapshots was causing we had to delete the application dr-iscsi and create new simple volume. Now we only have one netapp application with this issue - but it is much larger and we can not delete it:

=============================================================================
Vserver: ISCSI-NFS-DR
Application: drnfsds03
Application Template: VSIOnNAS
=============================================================================

Application Protection Information
----------------------------------
Is Supported: true
Is Protected: true
Local RPO: hourly
Local RPO Description: 24 hourly, 7 daily, 2 weekly snapshots
Remote RPO: none
Remote RPO Description: none

NAS Storage Element
-------------------
Component: vsidata_ds
Storage Service: value
Element: drnfsds03_sata
Path: /drnfsds03_vsidata_ds_1
Size: 40TB
Export Policy: esxi-dr-host
Press <space> to page down, <return> for next line, or 'q' to quit...

 

We are manually deleting the snapshots as they fill up my storage: 

 

-c01::application*> snapshot show -vserver ISCSI-NFS-DR

Vserver: ISCSI-NFS-DR

Application: drnfsds03
Protection Group: drnfsds03
Snapshot Creation Time Type
---------------------------------------- ------------------------ -----------
pg-hourly.2020-08-13_1730 Thu Aug 13 17:30:00 2020 crash
pg-hourly.2020-08-13_1830 Thu Aug 13 18:30:00 2020 crash
pg-hourly.2020-08-13_1930 Thu Aug 13 19:30:00 2020 crash
pg-hourly.2020-08-13_2030 Thu Aug 13 20:30:00 2020 crash
pg-hourly.2020-08-13_2130 Thu Aug 13 21:30:00 2020 crash
pg-hourly.2020-08-13_2230 Thu Aug 13 22:30:00 2020 crash
pg-hourly.2020-08-13_2330 Thu Aug 13 23:30:00 2020 crash
pg-daily.2020-08-14_0010 Fri Aug 14 00:10:00 2020 crash
pg-hourly.2020-08-14_0030 Fri Aug 14 00:30:01 2020 crash
pg-hourly.2020-08-14_0130 Fri Aug 14 01:30:00 2020 crash
pg-hourly.2020-08-14_0230 Fri Aug 14 02:30:01 2020 crash
pg-hourly.2020-08-14_0330 Fri Aug 14 03:30:02 2020 crash
pg-hourly.2020-08-14_0430 Fri Aug 14 04:30:04 2020 crash
pg-hourly.2020-08-14_0530 Fri Aug 14 05:30:00 2020 crash
pg-hourly.2020-08-14_0630 Fri Aug 14 06:30:00 2020 crash
pg-hourly.2020-08-14_0730 Fri Aug 14 07:30:00 2020 crash
pg-hourly.2020-08-14_0830 Fri Aug 14 08:30:00 2020 crash
17 entries were displayed.

 

thanks

BFry

you can try disabling the 'pg-' snapshot policies

 

cluster::*> volume snapshot policy modify -policy
default default-1weekly default-4weekly
none pg-rpo-15-minutely pg-rpo-6-hourly
pg-rpo-hourly pg-rpo-hourly-set2 pg-rpo-hourly-set3
pg-rpo-hourly-set4

 

cluster::*> volume snapshot policy modify -policy pg-rpo-hourly -enabled false

 

Public