ONTAP Discussions

Error while initiating node halt

dcabs
2,086 Views

Hello, do pardon me if I'm not expressively clear with my situation. Quite new to NetApp and the Powershell CLI.

 

So I was trying to initiate shutdown of my FAS2750 storage, I initiated the command "Stop-NcNode -Name *". However, I face with this error attached per photo. Not too sure what went wrong, I did read through the cmdlet help, seems like hitting dead end too.

Netapp.png

I'm using the latest Powershell Toolkit 9.7.1. 

 

Any solution or help is greatly appreciated!

1 ACCEPTED SOLUTION

anungw
1,601 Views

Hi All, is there any solution for this error? I encountered the same error.

ONTAP version 9.7P6

Powershell toolkit 9.7.1

View solution in original post

5 REPLIES 5

maffo
2,010 Views

hi @dcabs 

I believe the CMDlet is passing an option to ONTAP which is not clearly understood.

What version of ONTAP are you trying this on? You can check it by running Get-NcClusterImage

I have tested this with toolkit 9.7 and an ONTAP 9.5 I have here and I'm seeing your same behavior.

dcabs
1,978 Views

Unfortunately, I will be out of office till next week.

If my memory serves me right, it's currently on 9.5P1.

anungw
1,602 Views

Hi All, is there any solution for this error? I encountered the same error.

ONTAP version 9.7P6

Powershell toolkit 9.7.1

anungw
1,482 Views

I managed to halt the node using Invoke-SystemApi -RequestXML $xmlDoc 

$xmlDoc = New-Object system.Xml.XmlDocument
$xmlDoc.loadXml("<system-node-shutdown>
<node></node>
<ignore-quorum-warnings>True</ignore-quorum-warnings>
<is-inhibit-takeover>True</is-inhibit-takeover>
<is-skip-lif-migration-before-shutdown>True</is-skip-lif-migration-before-shutdown>
</system-node-shutdown>")
$nodeshut = $xmlDoc."system-node-shutdown"

anungw
1,590 Views

Hi @dcabs , are you able to solve the issue?

Public