ONTAP Discussions

Fas3140 7 Mode Disk Firmware update problem

JoeG617
3,892 Views

downloaded lastest firmware and DQP for disk but ontap fails to downoad to disk. this array is slightly aged but matric show that disk fw and ontap are compatible.

NetApp Release 8.0.3P4 7-Mode: Thu Sep 6 17:56:38 PDT 2012

 

sysconfig -a shows X412_S15K7560A15 is compatible with this version of on tap

00.3 : NETAPP X412_S15K7560A15 NA03 560.0GB 520B/sect (6SL7XCHN0000B4250U47)

00.4 : NETAPP X412_S15K7560A15 NA03 560.0GB 520B/sect (3SL19TSN00009108HZVR)

 


DQP file date
#
# Datecode: 20141210
#
sffas1>

 

 

sffas1> Fri May 1 16:31:00 EST [sffas1: raid.disk.offline:notice]: Marking Disk /aggr1/plex0/rg1/1a.01.13 Shelf 1 Bay 13 [NETAPP X412_S15K7560A15 NA03] S/N [6SL7XG7R0000B425100N] offline.
Fri May 1 16:31:00 EST [sffas1: bdfu.selected:info]: Disk 1a.01.13 [NETAPP X412_S15K7560A15 NA03] S/N [6SL7XG7R0000B425100N] selected for background disk firmware update.
Fri May 1 16:31:00 EST [sffas1: dfu.firmwareDownloading:info]: Now downloading firmware file /etc/disk_fw/X412_S15K7560A15.NA06.LOD on 1 disk(s) of plex [Pool0]...
Fri May 1 16:31:11 EST [sffas1: disk.senseError:error]: Disk 1a.01.13: op 0x3b sector 0 SCSI:illegal request - (5 26 98 0)
Fri May 1 16:31:11 EST [sffas1: dfu.fwDownloadFailedWbuf:error]: Write buffer command failed to Disk 1a.01.13 [NETAPP X412_S15K7560A15 NA06] S/N [6SL7XG7R0000B425100N].
Fri May 1 16:31:12 EST [sffas1: raid.disk.online:notice]: Onlining Disk /aggr1/plex0/rg1/1a.01.13 Shelf 1 Bay 13 [NETAPP X412_S15K7560A15 NA03] S/N [6SL7XG7R0000B425100N].
Fri May 1 16:33:12 EST [sffas1: raid.disk.offline:notice]: Marking Disk 1a.01.14 Shelf 1 Bay 14 [NETAPP X412_S15K7560A15 NA04] S/N [6SL7J1ZW0000N41802F9] offline.
Fri May 1 16:33:12 EST [sffas1: bdfu.selected:info]: Disk 1a.01.14 [NETAPP X412_S15K7560A15 NA04] S/N [6SL7J1ZW0000N41802F9] selected for background disk firmware update.
Fri May 1 16:33:12 EST [sffas1: dfu.firmwareDownloading:info]: Now downloading firmware file /etc/disk_fw/X412_S15K7560A15.NA06.LOD on 1 disk(s) of plex [Pool0]...

 

 

any help is appreciated.

6 REPLIES 6

rwelshman
3,878 Views

Is the firmware not updating for all disks, all disks of a certain model, or a particular disk?

JoeG617
3,871 Views
All disks being updated are X412_S15K7560A15 in either na02 or na03. They all fail to update with the same "write buffer command failed" error。

JGPSHNTAP
3,863 Views

you need to be running something a little more current if you can.. 8.0.3 is oooold.

JoeG617
3,769 Views

we upgraded to ontap 8.1.4P1 now firmware still fails to update. anyone idea?

rwelshman
3,762 Views

Would you be able to find a version 04 file and see if it can upgrade to that firmware first before going to 06? Or try downloading the firmware file again?

JoeG617
3,760 Views

found the NA04 version, it is going well. thanks. 

 

maybe i just can't go straight to NA06 thats why. 

 

sffas1> Fri May 8 12:41:11 EST [sffas1:raid.disk.offline:notice]: Marking Disk /aggr0/plex0/rg0/1a.01.0 Shelf 1 Bay 0 [NETAPP X412_S15K7560A15 NA03] S/N [6SL7XCBN0000B4250V8F] offline.
Fri May 8 12:41:11 EST [sffas1:bdfu.selected:info]: Disk 1a.01.0 [NETAPP X412_S15K7560A15 NA03] S/N [6SL7XCBN0000B4250V8F] selected for background disk firmware update.
Fri May 8 12:41:11 EST [sffas1:dfu.firmwareDownloading:info]: Now downloading firmware file /etc/disk_fw/X412_S15K7560A15.NA04.LOD on 1 disk(s) of plex [Pool0]...
Fri May 8 12:41:55 EST [sffas1:raid.disk.online:notice]: Onlining Disk /aggr0/plex0/rg0/1a.01.0 Shelf 1 Bay 0 [NETAPP X412_S15K7560A15 NA03] S/N [6SL7XCBN0000B4250V8F].
Fri May 8 12:41:55 EST [sffas1:raid.rg.recons.start:debug]: /aggr0/plex0/rg0: starting reconstruction, using disk 1a.01.0
Fri May 8 12:41:55 EST [sffas1:raid.rg.recons.done:debug]: /aggr0/plex0/rg0: reconstruction completed for 1a.01.0 in 0:00.09

Public